logic pro x mixer issues

Flou242
Flou242 Member Posts: 10 Newcomer
edited June 2023 in Komplete Kontrol

Hi,

I use the S49 mk2 in conjuction with an old logic control and i'm facing issues with the mixer control in logic pro x :

  • instrument en external midi tracks can't be controlled by the knobs, while audio , master and fx do.

Do i have to change a parameter or so ?

I already deleted the logic control in the control surfaces, but that doesn't help.

Greetings.

Pierre

Best Answer

  • Bl23
    Bl23 Member Posts: 3 Member
    Answer ✓

    Looks like the issue has been fixed with 10.7.9 update!!! Tried a couple of projects and was working as it should. Thanks for the assistance.👍️

«1

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 4,004 Expert
    edited June 2023

    Are you talking about the knobs on your logic controller or the ones on the s49?

    If what you want to achieve is controlling the parameters of an NKI compatible instrument with the knobs of the S49, it must be loaded inside Komplete Kontrol Plugin. This will give you access to all NKI functionalities, as opposed to using the keyboard in midi mode.

    Maybe have a look at this video, specially from 6:11. It could help you clarify how the S49 can work inside of Logic


  • Flou242
    Flou242 Member Posts: 10 Newcomer

    Thx for your quick response.

    well, that’s just the problem : if the track is a vst or an external midi instrument, I can not adjust the volume. It doesn’t respond when I turn the knob. The midi indicator doesn’t show activity neither. Very weird, as this is not happening to an audio track.

  • Flou242
    Flou242 Member Posts: 10 Newcomer

    Btw, I was talking about the knobs on the keyboard.

  • LostInFoundation
    LostInFoundation Member Posts: 4,004 Expert

    So…is your problem only when you engage the mixer on the keyboard?

  • Flou242
    Flou242 Member Posts: 10 Newcomer

    Yes, if I change the order of the tracks, then I can use it to control the volume.

    also when I turn the knob, nothing happens. I have a small film to illustrate, but it looks it is not allowed as a annex

  • Flou242
    Flou242 Member Posts: 10 Newcomer

    Also the pan doesn’t work on those tracks.

    If I use the fader on the Mackie control, on the screen of the kun the volume changes. The same thing as it concerns the pan.

    So it seems to me that no midi is sent for vst, external midi and drum tracks.

  • Flou242
    Flou242 Member Posts: 10 Newcomer

    Kun = kyb (keyboard) ☺️

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,833 mod

    @Flou242 We saw a couple of reports but could not reproduce the issue. Can you reproduce it if the logic control is not connected? What plug-in have you loaded in the instrument track? What's your OS? Is it a M1 Mac or Intel?

  • Flou242
    Flou242 Member Posts: 10 Newcomer

    Hi Jeremy,

    I tried, without the mackie been connected, and it's the same.

    I run everything on a new Mac Studio M2 Max.

    Greetings.

    Pierre

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,833 mod

    @Flou242 If you delete, or at least, temporariliy move these 2 files, does it fix the issue?

    Mac HD -> Users -> User Name -> Library -> Preferences -> com.apple.logic.pro.cs

    Mac HD -> Users -> User Name -> Library -> Preferences -> com.apple.logic10.plist

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:


  • Flou242
    Flou242 Member Posts: 10 Newcomer

    Jeremy,

    I deleted the files, but nothing happened.

    If i control the volume and the pan with the mouse in logic, i see it change on the screen of the s49.

    So to me it seems a midi out related issue.

    Greetings.

    Pierre

  • Flou242
    Flou242 Member Posts: 10 Newcomer

    The same happens when i want to mute or solo an instrument track.

  • About Me
    About Me Member Posts: 4 Member

    I have the same irritating problem. Instrument Tracks do not respond to any of the controls of my Komplete A61 keyboard. Everything else still works as expected. My guess is that this is a Logic Pro 10.7.8 bug. Can anyone verify if this happens with previous versions, please?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,833 mod

    @Flou242 I4ve contacted you by email regarding this issue, we need to have a deeper look.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,833 mod

    @About Me The issue seems to be a little different in your case as all tracks are not responding, as OP it's only for the instrument tracks.

    What's your operating system? Do you have an Intel mac or a M1? Is it happening in Rosetta/arm Native Accesstive/both?

    Does deleting the logic files mentioned in this thread change anything?

    Do Komplete Kontrol and Logic both have full disk access? How to Enable Full Disk Access on macOS

Back To Top