Native access can't install NTK

ageeee
ageeee Member Posts: 8 Member

Per attached error message happens trying to install NA version 3.3 which is supposedly silicon but that NTK package in the resources isn't.. what's going on?

All permissions set and ok file access etc etc

Monterey, Mac mini M1

Answers

  • Kubrak
    Kubrak Member Posts: 2,736 Expert

    I am not on Mac, but I think NTKDaemon is still x86. There is not AS version yet.

  • ageeee
    ageeee Member Posts: 8 Member

    Yeah cheers - what is confusing is that NA 3.3 blurb says doesn't need Rosetta. Then this error where it can't run NTK . And turns out NTK still needs Rosetta. What's the point of releasing 3.3 then?

    What on earth is NTK anyway?

  • Kubrak
    Kubrak Member Posts: 2,736 Expert

    I am not on Mac, maybe starting 3.3 NTK does not need Rosetta. I do not know.

    And it may be so that NA 3.3 is AS, but NTK still does not. NTK is program that actually installs SW and probably also authorise it. Sort of backend for NA that itself makes frontend.

  • Rich_NI
    Rich_NI Customer Care Posts: 173 mod

    Hi!

    With the release of Native Access 3.3.0, the NTKDaemon should no longer require Rosetta in order to run. It now runs natively on mac M1 systems.

    Please carry out the following steps:

    Go to Mac HD/Users/Shared

    Delete the "Native Instruments" folder.

    Restart Native Access. Does it then load correctly?

  • Dissekt
    Dissekt Member Posts: 4 Member

    Unfortunately, deleting this folder makes no difference.

    The NTK Daemon installer within the NA2 3.3.0 package contents still seemingly requires Rosetta 2 to run although the 3.3.0 installer no longer prompts for it to be installed.

    I believe that the devs are aware of this and are currently investigating.

    Thanks

  • Rich_NI
    Rich_NI Customer Care Posts: 173 mod

    Hi Dissekt,

    You are quite right, I just had a catch up with the devs. It seems that we have a bug with the new NTKDaemon that we are now investigating internally with the highest priority.

    In the meantime, you would still require Rosetta in order to install the NTKDaemon, and therefore Native Access.

    We will come back to you once we have an update on the issue. In the meantime, sorry for the inconvenience!

  • markj
    markj Member Posts: 3 Member

    Yes. And here we are at end of July, and the install of Native Access still invokes NTKDaemon which requires Rosetta on Apple Silicon:

    No thank you.

  • Hayo_NI
    Hayo_NI Product Team Posts: 262 mod

    Hey, for some insight why this is the case, our NTK Daemon as you can see in the screenshot above is boxed in an installer. This installer (and other product installers) are unfortunately the components that require Rosetta to run. We tried deprecating Rosetta and discovered this unfortunately, so we rolled it back. Going to revisit in Q4 and see how far along we are. NTK Daemon and Native Access can both run natively, it's just the installers unfortunately :/. Sorry about the inconvenience.

  • MHP
    MHP Member Posts: 1 Newcomer

    Hi @Hayo_NI ,

    it is Q4 now, any news on this topic?

    Trying to install Native Access (Mac M2 with Ventura 13.6) but NTK Daemon still requires the installation of Rosetta...

  • ageeee
    ageeee Member Posts: 8 Member

    6+ months on from my original comments about Rosetta in your installers and you still haven't fixed it?? I'm amazed anyone is still here to be honest. OS support behind, installers not working .. you'll need a new server just for all the NA messages. Come on! It's ridiculous - NI/PA/IZ - all the same..

Back To Top