S61 MK2 not working on logic pro for daw control

WernerG
WernerG Member Posts: 4 Sine
edited March 17 in Komplete Kontrol

Hello,

My S61 mk2 midi controller is not working on Logic pro X for daw control. It works fine with komplete kontrol.

I already removed the setup in "control surfaces", removed the file in the library preferences, and disable firewall.

Tagged:

Answers

  • WernerG
    WernerG Member Posts: 4 Sine

    Hello Uwe,

    I tried al the point in the article. I have Komplete Kontrol V2.6, Logic pro V10.7, and disabled the firewall. Still no connection between the midi controller and Logic pro.


    Werner

  • Uwe303
    Uwe303 Moderator Posts: 477 mod

    Ok but you see 2 midi ports for the keyboard one for midi notes and one DAW midi port?

    Uwe

  • WernerG
    WernerG Member Posts: 4 Sine

    When I'm in KOMPLETE kontrol (stand alone version), i can see these 2 ports (midi and daw).

    When I open Logic pro X, i can't see any device, so also no control ports

  • Uwe303
    Uwe303 Moderator Posts: 477 mod

    Ok then this could be the issue, I'm not a mac/logic user so I don't know how to go on with that issue. I googled "logic not showing midi ports" but the results where just what you've already tried.

    Uwe

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 918 admin

    Does the issue persist after enabling full disk access for Logic, Komplete Kontrol and all other NI software (+ re tarting computer and Logic)?

  • WernerG
    WernerG Member Posts: 4 Sine

    Hello Kaiwan,

    I did enable full disk access, restarted everything. Same result, no daw control.

  • Uwe303
    Uwe303 Moderator Posts: 477 mod

    As far as I can see Mac os has some system midi settings and routing capabilities, maybe you can check this settings. It's strange that the ports are visible in one program and not in the other.

    Uwe

Back To Top