Busy season in progress... Please note that due to a high volume of requests, the response time from our support is currently longer than usual. Chat is temporarily not available. We thank you for your understanding.

Help with Traktor S8 - stems not appearing in window

dubguy
dubguy Member Posts: 6 Sine

Greetings to everyone

I've been using traktor s4/s8's for years but recently upgraded to Macbook Pro M1 with my older Traktor S8 - everything seems to work fine except STEMS - they play without issue but intermittently appear on the window screen OR not. Sometimes it's only the master wave at the bottom of the window that shows and none of the 4 stems.

Being able to see the stems in the windows is crucial for my live shows so I'm wondering if there's I can do to fix it. I set up my old laptop and everything works great.

Thank you in advance for any info

Tagged:

Best Answers

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,609 admin
    Answer ✓

    Hi @dubguy can you please check if your Traktor Pro is the latest version? And for a workaround... try pressing 2 times the button on the top right corner of the screen and see if the stems are displayed.

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,609 admin
    edited July 26 Answer ✓

    You might need to downgrade to version 3.4.0...This is known to be the latest version that displays the stems properly. I've created a support ticket for you in case you need an installer.

Answers

  • Stevan
    Stevan MIDIMember Posts: 356 Saw

    I don't have this issue on M1 using D2 or S8. Did you try to reinstall the application?

  • dubguy
    dubguy Member Posts: 6 Sine

    Hi Stevan - thank you for your answer and suggestion. I did reinstall, made sure the update was applied. Then reinstalled again - the screen shot is what is the issue. Everything works, just no stems showing

  • dubguy
    dubguy Member Posts: 6 Sine
    edited July 21

    I noticed something today - if I have two stem sets loaded inti decks A & B and then go into Preferences Traktor8 / Restore - the Stems appear. If I load another Stem set - no visuals again (as above)

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,609 admin
    Answer ✓

    Hi @dubguy can you please check if your Traktor Pro is the latest version? And for a workaround... try pressing 2 times the button on the top right corner of the screen and see if the stems are displayed.

  • dubguy
    dubguy Member Posts: 6 Sine

    Hi @Kaiwan_NI


    Thank you for the suggestion. I think I've narrowed it down a little more.

    The Traktor 3 is updated to the current version. I checked the firmware for the S8. Same

    The potential bug in the system is this

    When I load a STEM is appears. if I load a single non-stem WAV file, the next time I load a STEM - the STEM tracks no not appear (as per the photo I uploaded).

    If I only load STEMS, there is no issue, they all appear as they should. It is ONLY when I play a non-STEM wav file that the following STEM tracks will not appear.

    What I've had to do is hit "restore" under the Traktor S8 preferences menu to bring the STEM visuals back

    Not ideal when playing a festival set but for now that seems to be the only option.

    Any further suggestions would be most welcome as I head into a run of shows this Friday.

    Thank you

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,609 admin
    edited July 26 Answer ✓

    You might need to downgrade to version 3.4.0...This is known to be the latest version that displays the stems properly. I've created a support ticket for you in case you need an installer.

  • dubguy
    dubguy Member Posts: 6 Sine

    Hi Kaiwan_NI

    Thank you for letting me know about the 3.4 version. I don't see it in my NI Access panel - it only states that 3.5 is the latest.

    If an installer could be sent that'd be great. I've had to hit the Traktor s8 restore a few times in between songs during my sets - it was a workaround but you can still here the resetting via audio.

    Thanks again for your help.

    Cheers

    Jesse

  • dubguy
    dubguy Member Posts: 6 Sine

    That worked.

    Thank you both for your help in getting this sorted out. Ran a festival show last night and everything worked as should.

    Much appreciated.

    Best

    Jesse

Back To Top