Komplete Kontrol S49 mk1 — MIDI templates disappeared

Stormchild
Stormchild JapanMember Posts: 24 Sine

All my custom MIDI templates have disappeared from my KK S49 mk1. I now just have a single template called "Templat1", and pressing the preset up/down buttons doesn't do anything (because there are no other templates).

Controller Editor still shows all my templates, but it seems to have lost the ability to communicate with my S49 (even though it says it's connected). Adding or modifying templates in Controller Editor has no effect on my keyboard.

Does anyone know how to factory reset the S49 or otherwise restore the ability to modify its settings with Controller Editor?

Best Answers

Answers

  • Stormchild
    Stormchild JapanMember Posts: 24 Sine

    One other detail — I know Controller Editor is successfully talking to my S49, because I can go into Preferences, select "Komplete Kontrol S - 1", and adjust the on/off-state brightness controls, and the brightness changes immediately on my S49.

    It's just the templates that aren't updating. I cannot edit or delete "Templat1". I can't add new templates. And although I still see all my custom templates in Controller Editor, there's no way to re-send them to the keyboard.

  • Mark90
    Mark90 Member Posts: 2 Noise

    Hi, I have the same problem and I have contacted NI who are looking into it. Out of interest are you running the software on a Mac? I used my windows pc and was able to change the midi assignments using the controller editor but not on my Mac. (BigSur)

    Managed to delete the new update on the Mac and install an earlier version of Komplete Kontrol from the NI site and have the templates working again. I needed to assign my continuous controller sustain pedal to send sustain(cc64) and not expression (cc 11) and the new update wasn’t allowing me to change it on my mk1 S88

  • Matt_NI
    Matt_NI BerlinAdministrator Posts: 748 admin

    @Jeremy_NI Any clue about what could be going on here?

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 987 mod
    Answer ✓

    Hey @Stormchild @Matt_NI This is probably related to the same issue with Maschine templates here:

    Solution would be the same, deleting this folder: Macintosh HD/Library/Application Support/Native Instruments/Hardware

    Then install the previous version of Komplete Kontrol: Komplete Kontrol 2.6.7

    Hopefully later today we will make a new version of Controller Editor available that will fix this issue.

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 920 admin
    Answer ✓

    Update: A new version of Controller Editor that addresses this issue is now available for download. More info on the same post above here.

  • Tijn71
    Tijn71 Member Posts: 8 Noise

    I am not able to see any of my F1 and Maschine Jam custom templates. Aslo both devices do not respond to the programmes they are mapped for. The F1 (effect mapping) does not work in Traktor anymore although all the required mapping is loaded.

    I had the Machine jam mapped to be used as a controller in Lightroom so I quickly edit photos. This is not possible now.

    I updated Maschine about a week ago and did not have any issues until yesterday evening.

    I can not downgrade because the required folder can not be deleted since it is in use. I tried to stop al NI services but it does not help.

    How to fix this?

Back To Top