Why is Reaktor 5 only using 3% of my i7 12700k processor but reports 45%?

TheTick
TheTick Member Posts: 4 Member

Hello,

Sorry for still using Reaktor 5.9.4 but I've had it since the early 2000's and still love creating in it.

So I am building a synth and it is not that demanding on the CPU but when I first load the program - and my synth in Reaktor - the CPU initially says 18% use then after about 20 seconds it rockets up to 45% CPU usage. I Process Lasso and other monitoring software installed and they report back that Reaktor is only using (in fact) 3-4% of my CPU.

I have an Intel i7 12700k overclocked to run at a fixed 4.7Ghz on all 12 cores.

I did read online that some people have disabled "Hyper Threading" in the BIOS - which I have done but it still jumps up to 45% (even though it's really only using 3-4%).

Does anyone know what's going on and how I can configure my BIOS so that Reaktor will properly use the CPU and stay low when running my programs?

(BTW: this even happens to ANY Ensemble that I load up, including things like Razor etc - so it's not just my synths)

Thanks

Jim

Best Answer

  • Kubrak
    Kubrak Member Posts: 2,719 Expert
    Answer ✓

    Also, 12th intel gen. uses big-little. It may happen Win sheduler first allocates Reaktor thread to big core and later on decides to move it to "efficiency" one. It could explain that Reaktor starts report the double the load than at the start.....

    Look in Win Device/System Monitor to see which CPU core is loaded by Reaktor and if the load does not jump from "performance" core to "efficiency" one.

    Also, you do not mention, which Win you use. Win 10 does not treat big-little well, it treats it rather badly. Win 11 is better in this respect.

    Another thing that might be worth experimenting is to switch off all efficiency cores. Reaktor 5 is not big-little aware for sure, Reaktor 6 might have some kind of patch to set preference to performance cores. But I do not know, if it has something like that.....

    Intel's implementation of big-little is IMHO total insanity almost approaching crime. Something like that should not be placed on market.

Answers

  • Uwe303
    Uwe303 Moderator Posts: 2,883 mod

    Hello,

    music stuff is time critical, so that's one cause why the difference is there. A project, for example, can start to crackle way before your CPU shows 100 percent. I'm not totally sure but reaktor runs on one core, so that's maybe another reason.

  • MosheB
    MosheB Member Posts: 3 Member

    Reaktor's CPU meter doesn't show the overall CPU usage only the load of the audio thread, take a look here:

    Reaktor 5.5 Application Reference English (native-instruments.com) at page 414. this will explain why you can see a load on that meter even its only 3-4% of your overall CPU usage.

    but its looks like you got some other problem in your system, it's not normal for the CPU to jump after 20sec like you say appends to you with any ensemble you try. It's not possible to know what can cause your issue try updating your system drivers maybe.

  • colB
    colB Member Posts: 746 Guru

    The jump up to higher % is possibly due to the efficiency settings. If windows thinks the overall usage is low, it might throttle back the cpu clock. Problem is then that single core the Reaktor is using gets cut back and so the % you are using jumps up.

    There is a NI page all about how to tune your system settings for digital audio

    There's on for mac too iirc... probably good to do some googling on the subject. You can make a big difference to the performance with all the right settings. But they do depend on your system - what works for one system might not for another.

  • Uwe303
    Uwe303 Moderator Posts: 2,883 mod

    Maybe run DPC latency checker and see if there is an issue.

  • TheTick
    TheTick Member Posts: 4 Member

    Thanks for all of the comments so far.

    I will try to look at the Reaktor page that talks about tuning your system, but if I (reluctantly) upgrade to Reaktor 6, would that help in any way? Does 6 do better with system resources and multi core processors or is it just a cosmetic change to the program?

  • Kubrak
    Kubrak Member Posts: 2,719 Expert
    Answer ✓

    Also, 12th intel gen. uses big-little. It may happen Win sheduler first allocates Reaktor thread to big core and later on decides to move it to "efficiency" one. It could explain that Reaktor starts report the double the load than at the start.....

    Look in Win Device/System Monitor to see which CPU core is loaded by Reaktor and if the load does not jump from "performance" core to "efficiency" one.

    Also, you do not mention, which Win you use. Win 10 does not treat big-little well, it treats it rather badly. Win 11 is better in this respect.

    Another thing that might be worth experimenting is to switch off all efficiency cores. Reaktor 5 is not big-little aware for sure, Reaktor 6 might have some kind of patch to set preference to performance cores. But I do not know, if it has something like that.....

    Intel's implementation of big-little is IMHO total insanity almost approaching crime. Something like that should not be placed on market.

  • TheTick
    TheTick Member Posts: 4 Member

    Hi Kubrak and thanks for your input.

    Yes, I am using Windows 10 but can easily upgrade to 11 without issue.

    And I think you are spot-on. When I use Core Temp software, it shows that Reaktor is sitting in the lowest cores (8-12) and those are the Efficiency Cores. So I will research on how to turn those off and see if I can keep Reaktor up on my main cores.

    And if you'd like, we can start a civil law suit again Intel due to their criminal use of Efficient Cores (lol).

    Jim

  • TheTick
    TheTick Member Posts: 4 Member

    KUBRAK!

    You little genius, you!

    Disabling the Efficient Cores worked PERFECTLY.

    A Reaktor synth that was taking up 45% as reported by the Reaktor CPU gauge, now only takes up 27%.

    And I can drop that further by overclocking the CPU even more if I so desire.

    Kudos to you, that was the exact right answer!


    Jim

  • Uwe303
    Uwe303 Moderator Posts: 2,883 mod

    You also could maybe set the affinity for the programs you want to run on power cores. But disabling e cores of course works well and always automatically. But maybe you have a look: https://www.makeuseof.com/how-to-manually-allocate-cpu-cores-windows-10/

  • Uwe303
    Uwe303 Moderator Posts: 2,883 mod

    Wow that intel makes such a mistake @Kubrak is right about that: https://www.xmg.gg/en/news-tips-and-tricks-rendering-e-cores/

  • Kubrak
    Kubrak Member Posts: 2,719 Expert

    @TheTick Good to hear, that it has helped. Also setting affinity a Uwe303 suggests might be a solution. I do not have experience with that, I am not using latest Intels on purpose.... Will take few years till programs will adapt to big-little on Win. At least moderatelly. And I prefer Win 10, I have moved to them a year ago and plan to stay on them for next five years at least....

Back To Top