Using a pedal to trigger start and stop in sampling mode

King swen
King swen Member Posts: 26 Member
edited January 2023 in Maschine

I connected a pedal and it doesn't trigger the sampler start and stop like it should. I get it to trigger when holding down the pedal for a few seconds but no way to time it and it doesn't trigger every time. Very intermittent. The manual says that you should just be able to push the button once and it will trigger the start in the sampler. I'm not sure if I'm using the wrong type of pedal but it is doing this with two different pedals and they function fine outside of sampler mode. I still need to try with my Boss FS6 that has more settings that can be adjusted. Might be a glitch they need to update. Anyone get a pedal to work correctly in sampler mode?


Update: This is with Maschine Plus in standalone mode.

Best Answer

  • Peter Harris
    Peter Harris Member Posts: 470 Pro
    Answer ✓

    Sounds like the Pedal mode might be set to "Continuous". Open Komplete Kontrol and check out the PEDAL tab and make sure the mode for Pedal A is set to "Switch".

    Also confirm that the MIDI mode right below in that same tab that is set to "Trigger" or "Toggle". Try it both ways.

    Many pedals also have a switch them that toggles polarity so you could try changing it to the other setting.

    In the meantime, does anyone know what specific MIDI CC Maschine uses for this sample trigger function? That also needs to be set correctly in KK on that same Pedal tab.

    Good luck!

Answers

  • Peter Harris
    Peter Harris Member Posts: 470 Pro
    Answer ✓

    Sounds like the Pedal mode might be set to "Continuous". Open Komplete Kontrol and check out the PEDAL tab and make sure the mode for Pedal A is set to "Switch".

    Also confirm that the MIDI mode right below in that same tab that is set to "Trigger" or "Toggle". Try it both ways.

    Many pedals also have a switch them that toggles polarity so you could try changing it to the other setting.

    In the meantime, does anyone know what specific MIDI CC Maschine uses for this sample trigger function? That also needs to be set correctly in KK on that same Pedal tab.

    Good luck!

  • King swen
    King swen Member Posts: 26 Member

    I was able to change this with the controller editor and Komplete Kontrol to "toggle" and it works correctly now. There is a slight lag but I think it will work. It would be awesome to get rid of the lag though.

  • Glenn
    Glenn Member Posts: 10 Member

    When you say you were able to change this with "controller editor" and Komplete control to toggle.. I am unsure how this helped?


    Doesn't controller editor only apply when the device is in midi mode, not when its in Maschine mode? I changed properties including the CC it sends for the pedal and nothing changed its behaviour.

    Dosent Komplete Kontrol only support keyboards.. when I run it there is no option to configure anything for the Maschine?

    The issue is for me that it is intermittent just like you said.. but changing it to toggle didn't make any difference for me.. when I go into Complete control I can see via monitor that its now sending different controllers but isn't that just ignored anyway when the devices is in normal mode (non midi mode) ?

  • D-One
    D-One Moderator Posts: 2,755 mod

    @Glenn asked:

    When you say you were able to change this with "controller editor" and Komplete control to toggle.. I am unsure how this helped?

    I'm also unsure what KK has to do with any of this, maybe typo?

    Doesn't controller editor only apply when the device is in midi mode, not when its in Maschine mode? I changed properties including the CC it sends for the pedal and nothing changed its behaviour.

    For the most part yes, but the Pedal is an expectation as well as Host Transport Control, both affect Maschine SW.

    The issue is for me that it is intermittent just like you said.. but changing it to toggle didn't make any difference for me.. when I go into Complete control I can see via monitor that its now sending different controllers but isn't that just ignored anyway when the devices is in normal mode (non midi mode) ?

    Nah. What controller do you have? Enable MIDI mode on your controller and go to CE settings, mess about with it and try recalibrating. It's quite unintuitive that the controller has to be in MIDI Mode to change something that affects the software aswell.

    I don't have a pedal to fully test it but i jammed a stereo jack in there and plugged some headphones to it to make contact and it worked fine for continuous messages as well as play/stop.

  • Glenn
    Glenn Member Posts: 10 Member

    I have discovered some more things about this.. I don't know why but my momentary switches that work fine with guitar.. and work fine for the start / stop .. and toggle record.. will not work when starting sampling. However a piano pedal (momentary) I also have works for start stop ... or toggle record.. and works perfectly for starting sampling.

Back To Top