Can't listen via headphones on my laptop

I've just upgraded to the latest Traktor 3.7.0 336. When I'm running Traktor on my laptop direct (not using the S4 controller) I can non longer listen to tracks using just my headphones. Only via the laptop speakers. Can anyone help?

Answers

  • zephry
    zephry Member Posts: 560 Pro

    First check your audio output settings in Traktor. Make sure the master out is selected correctly. After a new install it might not be selected.

    Depending on what drivers are available, you might need to select a different driver in Traktor audio preferences.

    Or you might need to switch what is playing on the laptop see if you can change the sound output down in the right corner where you adjust volume.

    I have noticed output between speakers and headphones and also switch to microphone input isn't as simple as it used to be the last couple years on newer laptops. Updates? I'm am not sure what changed.

    Another option I use is Asio4all. You can download free at https://www.asio4all.org/. This is what most people use when dealing with unreliable drivers.

    When you select Asio4all you can change output to headphones there.

    On my laptop that I use for editing without my S4mk3 connection, I use windows Wasapi for laptop speakers and Asio4all for the headphones.

    Also if you get strange slowdowns or horrible sound when you select a driver that plays. Always change the bitrate to 41000 or 48000. For some reason it sometimes defaults to the highest bitrate.

  • DJDancinDave
    DJDancinDave Member Posts: 21 Member

    Hey! Did you ever get this figured out? I'm having the same problem. If I don't have my S2 connected to my Macbook, the only Output options I get in Traktor are "1" and "2" — which only go thru the laptop speaker and I can't use headphones.

    I'm 100% positive I used Traktor DJ2 with headphones and no controller. Is that not an option in Traktor Pro 3? Sometimes I just wanna organize music etc. on the fly with no controller using headphones.. or pre-listen to a mix thru speakers while I'm working, etc. I'm sure there has to be a way!?

  • c0nsul
    c0nsul Member Posts: 292 Pro

    You have to manually select headphones output in audio preferences of Traktor.

  • DJDancinDave
    DJDancinDave Member Posts: 21 Member

    thanks! Yeah I realized I have to change the soundcard (audio inteferace) on the first tab of traktor settigns. I thought the same audio interface would access my laptop speakers and audio jack... but shockingly this is not true..!!

Back To Top