Brand new Maschine+ with blank left screen

mzkd
mzkd Member Posts: 4 Newcomer

Hi,

Anyone know what's going on with NI Support? I had a shiny new Maschine+ delivered last Friday morning but the left hand screen was just blank. No sign of damage to the device or the packaging so I'm wondering if there's anything I can do or whether it's straight dead on arrival.

Either way I've not heard anything back from support since I raised a case on Friday.

I managed to get the device connected, registered and updated using just the left screen but obviously can't do much more :(

Put it in 'Las Vegas' mode but no change.

Not sure what else I can do...

Tagged:

Comments

  • D-One
    D-One Moderator Posts: 2,672 mod
    edited December 2022

    Well... never seen that before on the forum, I'm amazed you got thru registration without one of the screens tbh. That really looks like an HW issue, maybe something simple like a loose cable to one of the screens. Try resetting the unit, will be very awkward without 1 screen but I can detail the steps:

    1. Press Settings.
    2. Press Right 6 times (top 6th button) until you see "Settings" on the right screen.
    3. Hold Shift and press top button #4
    4. A confirmation should show up on the right screen, confirm and reset the device.
    5. Pray it works.

    If it fails only tech support can help, you will probably need to exchange for a new unit. Depending on what time you submitted your ticket on Friday it's only been 2 working days, which is acceptable. This is a complicated time at tech support due to Xmas.

    I would wait till tomorrow and if there's no answer bump the ticket.

  • mzkd
    mzkd Member Posts: 4 Newcomer

    Thanks for the response @D-One :)

    I'll give that a try. I do understand it's a busy time for Support but couldn't find any SLA or anything to give me a clue about normal response times. Probably getting impatient as I kinda wanna play with my new toy!

  • mzkd
    mzkd Member Posts: 4 Newcomer

    Okay minor update...

    Managed to perform a system reset but no change. Thanks for the idea though.

    Guess I'll continue to wait for Support.

  • queue
    queue Member Posts: 3 Member

    MK3 here, but just now got that same issue. Left screen constantly white..

  • GödelEscherSpock
    GödelEscherSpock Member Posts: 6 Member

    Just FYI'ing in here.

    New MK3 yesterday (Dec 14 too), slightly newer firmware than the one you can download from the website.

    Screens are fine.

  • mzkd
    mzkd Member Posts: 4 Newcomer

    Update on this.

    Finally got contact from NI Support, very helpful support person Cris - who has identified it as a hardware fault and is organising a return.

    Not sure what's going on now as comms have gone quiet again but I suspect they may be waiting to receive my old unit rather than sending a new one right away which would've been nice.

    @queue I'd say get on to support asap if you have a white screen - my gut feel is this indicates screen power but no signal connection or similar so it doesn't seem likely to me that firmware will fix it.

    Good luck.

  • D-One
    D-One Moderator Posts: 2,672 mod
    edited December 2022

    Well... You're really unlucky to have this happen near XMAS where both support and shipping is slower. I think it needs to reach them before they send you a new one or fix yours, not sure what they do in such cases.


    @queue I'd say get on to support asap if you have a white screen - my gut feel is this indicates screen power but no signal connection or similar so it doesn't seem likely to me that firmware will fix it.

    It could be just a loose cable, support would never tell you open the unit and check the cable, that makes no sense for a new unit under warranty and the user could break the unit making it worst, but.. for a user that has an MK3 for years and its out of warranty it might be worst a shot.

  • queue
    queue Member Posts: 3 Member

    Thank you friends.


    I've already contacted support, and NI have initiated an return for repair.

    Hope it resolves soon!

Back To Top