Missing Kits and Samples in Battery 4

Ama
Ama Member Posts: 8 Member

I just upgrade to Komplete 14 Unlimited Edition. The first 2 days everything works fine. Battery 4 had a tone of new kids and samples. But after I open Logic Pro x yesterday, there were only 3 kits and a few samples.

I reinstalled Battery 4, rescaned the libraries in the preference of Battery 4, try to resolve it automatically and manually in the "Missing Samples" option of Battery 4. Nothing worked.

Its the same issue in the standalone Battery 4 Version.

Thank you for your support!

Best Answer

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,887 mod

    @Ama Make sure that Battery and Logic have Full Disk Access: How to Enable Full Disk Access on macOS

    Restart your computer, does that fix the issue?

    If not, where are your Battery kits and samples stored on your computer? On an external hard drive? What is the format of that drive?

    Also, what is your Operating system? Is it a M1 Mac or an Intel Mac?

  • Ama
    Ama Member Posts: 8 Member

    Both have Full disk Access. The samples and kits are stored on the Mac and on an external hard drive. Both systems have kits and samples that are missing. So it can't be a hard drive issue. The format is Mac OS Extended (Journaled). Im operating on a M1 Max.

    Thanks for your help

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,887 mod

    If you open Battery in standalone, are these kits missing? Are you running Logic in Rosetta mode ? Battery is not yet M1 native compatible.

  • Ama
    Ama Member Posts: 8 Member

    Yes they are missing in the standalone version too. I'm running Logic Pro X in Rosetta mode

  • FLASHOVER
    FLASHOVER Member Posts: 2 Member

    I'm having the exact same issue after updating a few days ago. I only have 3 battery kits as well. What's weird is that if I open a project that used a different kit it will still open and work but none of my kits or instruments show in the browser, so i still cannot change them.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,887 mod

    @Ama @FLASHOVER Are you on Ventura? Are the Battery kits and samples installed on an external hard drive? What format is that drive? There are known issues with Ventura and external hard drives, that could be an explanation here.

  • Ama
    Ama Member Posts: 8 Member

    I'm on Monterey. The Battery kits and samples are stored on the Mac and on an external hard drive. Both systems have kits and samples that are missing. So it can't be a hard drive issue. The format is Mac OS Extended (Journaled)

  • Ama
    Ama Member Posts: 8 Member

    @FLASHOVER

    Same for me.

  • FLASHOVER
    FLASHOVER Member Posts: 2 Member

    @Jeremy_NI @Ama I'm on Monterey and on a M1 Macbook running with Rosetta. The weird thing is that even though the browser wont show any of my kits and instruments, if I open a project where I already had them loaded they still work, so somehow it is still finding the libraries. This is making me think that it is just a bug with the Komplete update and not a hard drive issue.

  • Jamesie
    Jamesie Member Posts: 2 Member

    Not totally sure but with Monterey and M1 Macs you should format your drives with APFS

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,887 mod
    Answer ✓

    @Ama @FLASHOVER I contacted you by email, we'll need to have a deeper look in your systems.

  • David Willis
    David Willis Member Posts: 15 Member

    I contacted support recently because of missing amples in Battery 4 in both Studio One and Luna. Here is their reply: "We are aware of the issue you are facing with battery 4, as it is a known bug. Our team is actively working on a solution and we expect to release a fix in the near future."


    However, an internet search shows that the missing samples bug has been around since 2011! Why haven't they fixed a 13 year old bug?!?

    This is frustrating and disappointing. I have spent thousands on NI products because they sound great and are good to work with, so this anomaly is very grating.

  • feed.exe
    feed.exe Member Posts: 25 Newcomer

    when update?

Back To Top