The latest NA (v2.6.2) is blocking all update/downloads to Australian IP addresses

justsimplyme
justsimplyme Member Posts: 7 Newcomer

[NOTE: using a macOS 12.6 client system]

I submitted a bug report to NI. This is beyond annoying; it's hard not to use NSFW language when an issue of this magnitude arises. Here's what I sent NI when I found a mitigation:

------- begin email quote ------

Hi Native Instruments,

Regarding my recent bug report re: getting “waiting for connection”, since upgrading to NA v2.6.2...

Just verified that it is an issue with your network provider/engineers. Why am I sure?

Using any Australian IP addresses to access NI via “Native Access” v2.6.2 results in your systems verifying my licenses, BUT refusing to allow me to download ANYTHING at all (your system baulks immediately). I tried different IP addresses using (1) Apple’s “Private Relay” on macOS 12.6, (2) no Private Relay (ie. my ISP’s own IP address), and (3) using NordVPN with an Australian server/IP.

When I connected NordVPN to a German server (with a German IP), I was able to download my XXXXXX update, as well as my new XXXXXXXX purchase.

Please respond soonest, hopefully to tell me that you have found and fixed the issue.

I don’t have to tell you how stupid this makes you (and the vendors who use NI) look, when you claim to support the world’s leading musicians. I have already complained to XXXXXXX (from whom I purchased XXXXXXXX).

So much for German engineering.

------- end email quote ------

Best Answer

  • justsimplyme
    justsimplyme Member Posts: 7 Newcomer
    Answer ✓

    Yes. A few days after my issues (and my forum post on them), NI released Kontakt 7, which I purchased as an upgrade. I was able to download both Kontakt 7, and its huge associated library, without problems at high network speed.

    Nothing changed on my Mac or my network, so I maintain that there was a short-term network config issue at NI. I simply got a problem ticket response that the issue was solved, and was closed.

    In conclusion, there is not currently any network or connectivity issue, and instruments are licensing and downloading perfectly once again.

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,097 mod

    @justsimplyme My colleagues already got back to you with a few troubleshooting steps. Check your inbox and let us know if that worked out.

  • Russellmus
    Russellmus Member Posts: 38 Helper

    This is contrary to my experience with my Australian IP. With or without a VPN it works as expected (actually better than expected as I’ve come to expect NA installs to fail).

  • justsimplyme
    justsimplyme Member Posts: 7 Newcomer
    edited September 2022

    Thanks for all comments. I must say in fairness that Native Access has always worked well for me in the past (I have licensed and used many instruments without issue, all on this same hardware and macOs). This time though the app upgraded itself to the new version right at the start, and things went wrong.

    The NI troubleshooting steps are sensible. But the NA app already had all required macOS permissions for disk access (and changing my IP address wouldn’t change app behaviour at all in this regard). Being put in a “waiting queue” for downloads does suggest a network issue, you have to admit.

    Perhaps this was a transient network issue. I could try installing an additional free NI app, if there is one, and see if the same thing happens again. Also, it occurs to me that I could install NA and some instruments on my Windows laptop, on the same network, and see if the error persists on Windows. I shall do so and report back.

    Regards, M.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,097 mod

    @justsimplyme Any update on the topic?

  • justsimplyme
    justsimplyme Member Posts: 7 Newcomer
    Answer ✓

    Yes. A few days after my issues (and my forum post on them), NI released Kontakt 7, which I purchased as an upgrade. I was able to download both Kontakt 7, and its huge associated library, without problems at high network speed.

    Nothing changed on my Mac or my network, so I maintain that there was a short-term network config issue at NI. I simply got a problem ticket response that the issue was solved, and was closed.

    In conclusion, there is not currently any network or connectivity issue, and instruments are licensing and downloading perfectly once again.

  • Victor Spiegel
    Victor Spiegel Member Posts: 1 Newcomer

    I continue to get: DOWNLOAD FAILED. COULD NOT CREATE NEW FILE OR TRUNCATE EXISTING FILE.

    Please advise. How to download the file properly? I am running MacOS 12.6 M1 Ultra.

    thanks!!

    victor

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,097 mod

    @Victor Spiegel How is that issue related to the original object of that thread? Have you tried contacting our support already? http://bit.ly/NIsupport_install

Back To Top