Maschine Plus DIN MIDI not working

joebear Member Posts: 7 Newcomer
edited June 2022 in Maschine

I cannot get my Maschine+ to recognize MIDI coming in the DIN port.

I have a CME XKey25 attached to one USB host port, and a CME XKey37 attached to the other USB host port. I also have a DIN cable running from a Korg DS-8 MIDI out to the MIDI In on the Maschine+

In Settings: MIDI: Input Devices, all are set to On.

I have a sound set to


CHANNEL/MIDI: Channel: All

Hitting the associated pad outputs that sound

Hitting one of the USB-connected keyboards outputs that sound

Hitting the other USB-connected keyboard outputs that sound

Hitting the DIN-connected keyboard outputs NOTHING.

If I pull the DIN cable from the keyboard from the Maschine+ MIDI In, and plug it instead into the MIDI In of another sound generator, and hit that keyboard, it outputs sound - so I know the keyboard and cable are good.

How do I get the Maschine+ to recognize MIDI on its MIDI In DIN port?

System Version

Maschine Version 2.15.1 (R7)

Firmware 0.1.6



  • PK The DJ
    PK The DJ Member Posts: 531 Guru

    You don't mention it, but do you have anything plugged into the MIDI out of the M+?

    From what I hear, the in & out can't function simultaneously.

  • joebear
    joebear Member Posts: 7 Newcomer

    No, nothing plugged in to the Maschine+ MIDI Out port.

    Though the (possible) inability of using both MIDI In and MIDI Out seems extremely limiting. I have a hard time believing (especially given your 'from what I hear' language) that could actually be the case.

    Thanks though.

  • joebear
    joebear Member Posts: 7 Newcomer
    edited June 2022

    Hi DeepThumb -

    Yes, as I write in my initial report above, all the settings that I think may be germane from the manual page on midi settings are set correctly. Of course, I could be misinterpreting what the manual is saying. In which case, specific things to try would be most welcome.

    As far as the manual page you suggest on MIDI change, that seems to be focused upon invoking changes to Maschine+ Scenes, Sections, or Lock, by triggers of various MIDI events received via MIDI - either USB or DIN. That would seem to be more sophisticated processing than merely having the internal sounds respond to MIDI Note On/Note Off, no? As such, I would expect those settings to be irrelevant.

    I briefly considered the possibility that use of MIDI Note On as a trigger for some such MIDI Change event may conflict with using Note On to drive the sounds (as ludicrous as such a coupling would be), but toggling through the options there has not rendered the sounds capable of responding to MIDI Note On over the DIN port.

    Again, over USB, it works as expected. Over DIN, I cannot get it to work so far.

  • PK The DJ
    PK The DJ Member Posts: 531 Guru

    I've just searched for the post and actually it's related to MIDI clock.

    "Maschine+ can not recieve and send clock at the same time"

    Original post is here

  • darkwaves
    darkwaves Member Posts: 262 Pro
    edited June 2022

    I can confirm that a midi cable to/from my yamaha modx works. local off. Midi in and out pointed at the maschine ports. Routing works as expected.

    I usually use a midi interface. I unplugged it for the test. Plugging it back in; it still worked

    edit: double checked. I'm on firmware 0.1.9

    I never had midi issues, but that update states it's to address an issue where midi in stops working.

  • joebear
    joebear Member Posts: 7 Newcomer

    Hi PK the DJ -

    Not being able to simultaneously send and receive MIDI Clock seems more understandable. Thanks for following up with the clarification.

  • joebear
    joebear Member Posts: 7 Newcomer

    Hi darkwaves -

    Your FW observation looks to be a good area to explore. I'll see if I can get the FW updated, and report back.

  • joebear
    joebear Member Posts: 7 Newcomer


    Updating to FW 0.1.9 has resolved the issue.

    Thanks, darkwaves!

  • DeepThumb
    DeepThumb Member Posts: 155 Advisor

    everyone complaining without reporting the FW version or without having installed the most current FW version should be punished! 😉

  • joebear
    joebear Member Posts: 7 Newcomer

    Are you speaking of me?

    You may note I reported my FW version in my initial post.

    And silly me for believing Settings:System when it told me it was up to date, and did nothing to prompt me to check FW as well.

Back To Top