Problems with sound-routing while using OBS on Mac

Options
BluRay
BluRay Member Posts: 4 Newcomer

Hi,

I have a Kontrol S8 and Traktor Pro 3 and I want to stream with OBS.

When I connect the S8 via USB to the Macbook I were able to make an audioinputdevice in OBS which is working really well when I use the S8 which is already installed in the Audio devices. Except one thing. It's also palying the Cue from my headphones…

I have this setup.

I searched for a while and found some links which discribing to use Soundflower or Blackhole to connect it via virtual cable in OBS. this is also working fine but when then without microfone.

The mic is connected to the XLR input on the back and assigned to Deck D.

When I use it in live mode the levelbar is showing the mic input but I werent able to get it to my OBS. none of the Blackhole-devices are plaing the mic-signal.

In the Trakator settings I also tried nearly every input/output combination but the mic isn't recorded.

I tried the option c from the support-sheet

Is there a tutorial which is showing how to do it step by step?

Or would it be easier to use a audio-interface like the KOMPLETE Audio 2 and put the S8 to this and plug the interface onto the Mac?

I'm a little upset and hope anyone has had the same Problem in the past :)

Answers

  • Uwe303
    Uwe303 Moderator Posts: 3,296 mod
    Options

    Hello,

    here you can see it, just pause the video on all settings and copy it. It's not the best tutorial but it should help.

  • BluRay
    BluRay Member Posts: 4 Newcomer
    Options

    Thank you for this but it isn't working as expected.

    The main problem is still that the mic doesn't is working in OBS.
    The Volume of the Master is perfect. The cue on my headfones isn't hearable on the OBS input. When I volume up the D channel where the mic is conencted to (it's an XLR connected on the back of the S8) the volume is so low you can't realy hear it in the OBS.
    On the monitor (2 speakers connected to the S8) its perfect and also the volume level meter is nice. It's so annoying.

    I have some screenshots from my Traktor settings, maybe anyone can see a problem.

    The S8 is the device I created in the audio-midi-settings of the mac with the Blackhole cable (I used the 2 channel version now. previousely also tested it with the 16 channel version).

    Thank you all 😊

Back To Top