Maschine Plus MIDI Mode Velocity Sensitivity Problems

Styles01
Styles01 Member Posts: 26 Member

This has been documented elsewhere for other Maschine models, but I haven't noticed this problem as bad as with the Maschine Plus (I've had pretty much every other model), it seems so much more pronounced as a problem on the M+. Quite simply, the activation threshold is so much higher on the M+ in MIDI mode vs native (Maschine software or M+ standalone mode). For example, trying to actuate a pad in a DAW or even Melodics for example, is next to impossible vs in the native Maschine software. For reference, I have the sensitivity set all the way up in controller manager, the velocity on each pad fully open, and the velocity curve set to soft. Still nothing helps. It feels like this is a firmware issue.

Comments

  • D-One
    D-One Moderator Posts: 2,748 mod
    edited January 26

    It is def a firmware or SW/driver issue, how much voltage is required for activation when the Pad grafite sensor sheet activates the Pad switch PCB traces is a definable parameter... They can change it if they want but NI wont address it for some reason, quite infuriating. I have to pound the Pads each time I need MIDI Mode.

    MIDI Mode 'sensitivity' / minimum actuation force / threshold is indeed absolute garbage (and trust me, i don't use aggressive words like that lightly, if ever around here) especially if you develop muscle memory by using the Maschine SW where it's 100x better, I find it baffling that some people don't seem to notice.

    The MK3 and Mikro-MK3 had the exact problem and just as pronounced in my experience.

  • Styles01
    Styles01 Member Posts: 26 Member

    hmmm... weird I didn't notice it in the MK2 or MK3 as bad. Maybe it's cause I have other pad controllers now like the Push and the Minilab that really work great with apps like Melodics and Ableton, but I much prefer the size of the pads in the Maschine and I'd love to use it more for what it's great at which is the drum side of things. Annoying that they don't want to make it a more loved unit.

  • Styles01
    Styles01 Member Posts: 26 Member

    After doing some more scouring I did find a workaround that seems to mildly alleviate the issue, in a way. If you don't particularly care about velocity sensitivity, you can switch from Poly Pressure to Note Mode on each pad (or click and drag all of them in controller editor). In Note mode you can set the threshold down really low (to like 2%). This made Melodics seem to be about 25% more sensitive - I don't have to POUND the pads to get them to react, but they still aren't nearly as sensitive as in the Maschine software. There's some folks on the internet that seem to think this is related to some sort of internal driver that NI has chosen to control MIDI - I am hoping this gets addressed in a firmware update at some point.

  • tetsuneko
    tetsuneko Member Posts: 561 Guru
    edited January 30

    How about using a MIDI cable for loopback instead of using Maschine in MIDI mode? IIRC you can set up just about any controller to work with Melodics. Just create a group with 16 sounds that all send MIDI out

  • D-One
    D-One Moderator Posts: 2,748 mod
    edited January 30

    That's kind of what I would do but even simpler... I just use the built-in virtual driver to send MIDI from the Maschine app to another app.

    On Windows, it might be slightly more complicated as I think it has an inherent limitation of MIDI port exclusivity per app so one would probably need something like LoopBe.


    @Styles01 said:

    There's some folks on the internet that seem to think this is related to some sort of internal driver that NI has chosen to control MIDI - I am hoping this gets addressed in a firmware update at some point.

    I believe so, MIDI Mode for Maschine controllers is not class-compliant, meaning you can't plug a Maschine controller to say an HW synth or an iPad, it won't work because it needs drivers. It always needs to be connected to a computer with things installed on it... But if the actuation tresh is set there or the firmware I don't know but it's likely the driver since changing settings in Controller Editor changes how it behaves.

    I'd say it's probably NIHardwareAgent service that runs in the background.


    If you don't particularly care about velocity sensitivity, you can switch from Poly Pressure to Note Mode on each pad (or click and drag all of them in controller editor). In Note mode you can set the threshold down really low (to like 2%). This made Melodics seem to be about 25% more sensitive

    Interesting... I'll try this.

Back To Top