When will my Traktor S4 Mk1 be able to run on my mac monterey and sonama OS

Its super frustrating this is happening. The only way i can make it work is by restoring with Big Sur but then some hardware built in to my mac doesnt work like bluetooth for example. Then the only way to bring that back to life is by reverting back to the macs original OS which ofcourse disables the use of my traktor!

someone please shed some light on whether something is in the works to fix this?


thankyou in advance

Best Answer

  • victorp.sg
    victorp.sg Member Posts: 60 Helper
    Answer ✓

    Unfortunately, Traktor S4 Mk 1 is no longer being supported since 2019 when macOS 10.15 Catalina was released—32-bit support was dropped entirely from 10.15, only 64-bit from then onwards.

    Speculation on my part…most likely the manufacturer that produced the chipset used in Traktor S4 Mk 1 did not have 64-bit software tools and drivers for NI to upgrade their driver to 64-bit.

    So the answer to your question is that there will not be any fix available since macOS Catalina and any Mac computer released from 2019 onwards—the only solution is to find older Mac computers that can run macOS 10.14 Mojave and below properly.

Answers

  • victorp.sg
    victorp.sg Member Posts: 60 Helper
    Answer ✓

    Unfortunately, Traktor S4 Mk 1 is no longer being supported since 2019 when macOS 10.15 Catalina was released—32-bit support was dropped entirely from 10.15, only 64-bit from then onwards.

    Speculation on my part…most likely the manufacturer that produced the chipset used in Traktor S4 Mk 1 did not have 64-bit software tools and drivers for NI to upgrade their driver to 64-bit.

    So the answer to your question is that there will not be any fix available since macOS Catalina and any Mac computer released from 2019 onwards—the only solution is to find older Mac computers that can run macOS 10.14 Mojave and below properly.

  • Jordie featch
    Jordie featch Member Posts: 3 Newcomer

    Thank you Victor!

Back To Top