Xone K2, Xone:23C, (2019 MacBook), and Traktor Pro 3 - Please Help!

I'm trying to migrate over to those hardware pieces above, and Traktor Pro, and am using the map template from Native Instruments XK2-TP3-2DK4FX, and everything behaves as the instructions for setup, including import, lays out. But I cannot get it to fully function.

What I mean is, the play and cue buttons work. I should also say 1.) I've never mapped anything midi or over USB. But I have drilled down and checked everything that seems logical (channel, button action/behavior/etc.), and all that looks okay. As in, looks okay to someone who would miss something obvious. I'll upload a screenshot of the Controller Preferences window.

I feel pretty certain this is something simple that I just don't know about.

I'm also only trying to get tempo adjust and tempo bend working. I'll take sync, but I can live without it.

The fact play and cue work tell me the controller is communicating with the computer on the right channel. And the button assignment for, for instance, tempo bend (up and down) is mapped to the button the instructions says it should work on, although I've pushed every button on every layer (except the play or cue), none adjust the tempo. I've also tried "Learn" for the tempo options, and although I've never tried to use a different button than what the template file uses, it does behave like it recognizes the button being pressed. As well, every button and knob adjustment made on the K2 lights up the incoming midi signal icon on the Traktor window. The Mac and Traktor are seeing the signals.

Sorry for the length. I love the idea of ditching fake turntable platters and going as minimal as possible. And software is software; I've used VDJ, Serato, and now Traktor, and I'm sure I'll be happy with it. I'm just getting stuck on this one part.

The X2 and 23C are new, the Mac is 2019 with an update OS, and Traktor is updated. I bought this setup over a year ago and have spent more time than I care to admit trying to make it work on my own. Even though the solution may be simple, I will not ask to a fault. Learning on your own seems to be good.

In case it matters, I'm also using my Beatport account through Traktor for the library.

Anyway- thanks, and any help is appreciated!

Answers

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,521 mod
    edited December 2023

    The In-Port and Out-Port of the shown K2 mapping should be set to the K2 controller, not the 23C mixer.


    Edit: make sure, the K2 is working on channel 14 and the 23C is not on channel 14, just to be on the safe side. Did you connect both via usb?

  • stwilhite
    stwilhite Member Posts: 3 Newcomer

    Okay, great info.

    I tried changing the In and Out to the K2, and before I plugged it into the Mac with its own USB, I didn't see the option. I took screenshots and they are all here.

    Hopefully they make enough sense to decipher. The last image is the output capture of a Midi program I guess I downloaded months ago while I was trying to figure this out. I will say that after I opened that program to capture the signals, I pressed a few buttons on the 23C first (both USBs plugged in), and it didn't capture anything. It was only after I pressed the Play button on the K2 did the signal capture start working.

    It looks like they're both on channel 14, but I don't know how to change that for the 23C. Also, I can't say for sure the delay in the capture is defiantly due to no signals sent unless I press something on the K2.

    Thanks so much for the help- this is aggravating and I bet you've found the problem.

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,521 mod

    I am not sure about the ins and outs of the 23C, but i can test on my own K2 if you upload the XK2-TP3-2DK4FX-mapping as file in this thread.

    It may be helpful to change the channel in the mapping from 14 to (for example) 13 and for the K2 using the setup function to exclude any conflict with the 23C. Changing the channel for all mapping commands can be done quickly with the cmdr-mapping-editor so we can try this easily.

    It's rather strange the K2 is not in the dropdown list of the IN/OUT option for each mapping. Is it possible you used X-LINK via 23C to connect the K2 or did you connect via USB? Did you install the latest driver from A&H?

  • stwilhite
    stwilhite Member Posts: 3 Newcomer

    This is the map file. It came from Native Instruments.

    I also changed the midi channel to 13 on the K2, but I don't see where I can make a wholesale change to all the individual maps on the laptop (including within Traktor), but did finally figure out the "Learn" feature.

    So, I changed the K2 midi to 13, went through and "Learn" set the "M" button to "Play," the "I" button to "Cue," the A and B to Tempo Bend and the E and F button to Tempo adjust. And when I pressed the button on the K2, the assignment changed in the Preferences window to Ch 13 [same key name]. So, that worked, and is a step forward!

    However, only Play and Cue works. Neither of the tempo adjusts do. Again, the Traktor app is recognizing the button press, both when I tell it to learn what to look for, and when I'm testing it.

    Thanks again!

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,544 mod

    It looks like the driver is not installed like @Sûlherokhh pointed out. Otherwise, the midi port option would appear.

    23 doesn't have the X-Link option so channels are not issue probably.

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,521 mod
    edited December 2023

    So far the mapping works and looks good on my end. How do you link the K2 to your setup?

    As @Stevan supported my question, what about driver update?

Back To Top