Traktor Kontrol F1 Suddenly no Default Mapping

Nupol
Nupol Member Posts: 1 Newcomer

Hello,

i just bought a Kontrol F1 and tried it out and it worked really good. then i restarted Traktor and suddenly i got no Default mapping at all. i tried to load tsi file but the options are not the Default settings i had before and also i cant start / control the Remix decks at all. I reinstalled Everything from drivers to software. Made sure to unplug all hardware during driver install. The wizard only gives me an option to use default setting for the Kontrol X1 but not the Kontrol F1. I also deleted every mapping for F1 in Controller Manager. When i Load a tisi i get mappings in the list window but otherwise there is nothing at all. I just cant understand why it was working plug & play and suddenly i dont have the same funktionality no matter wich preset i load (lights are also completly different).

Can anyone help me with this. I just want the Device to Plug & Play and i dont wanmt to spend ages to configure it myself

Answers

  • Uwe303
    Uwe303 Moderator Posts: 2,900 mod
    edited December 2023

    Hello,

    if you open the preferences you have a wizard on the bottom, have you tried this? Maybe you activated the user midi mode but this controller normally has the NHL protocol, so there is no need to load TSI files, only if you want to do it and use shift + browse to switch between those modes as far as I understand.

  • Stevan
    Stevan Member Posts: 1,512 Expert

    Also check your Default Mapping folder (in my documents --> NI --> Traktor) and see if there is an F1 mapping in there.

    Reinstalling Traktor should fix this if so.

Back To Top