Traktor pro 3 not opening

Kruter Member Posts: 2 Newcomer

Hi! I recentrly got a Traktor Kontrol Z2 with a license for Traktor Pro 3. Getting everything downloaded was no problem but when i try and open Traktor i get a small window with the Windows red cross.

After this i uninstalled traktor, updated everything on my computer, deleted other programs for free space. Mostly got rid of all the possible faults.

After installation again I have the same problem, try running it as administrator does not help, I have the latest C++ visuals and my computer is up to spec (by NI´s demands) Intel core I5 with windows 10. The Native Access launcher works fine but none of the programs work.

Has anyone had the same problem? Customer service does not answer me so I ask you for help. I also included the error tab as a picture, this is all i get when starting it.


  • DJ SOS zzedsounds
    DJ SOS zzedsounds Member Posts: 14 Member


    I have not able to ise Traktor pro 3 for sometime now because it crashes on openninh after some updates made last time...I have tried to revert to older versions in Documents/Native Instruments folder but they all crash upon opening now. I never had issues like that whenever l reverted to the old version but from the time l updated it after the drum pattern version 2 l started having problems..l kindly need help by reverting to an independent older pro 3 version when the drum pattern and Ozone maximizer was just introduced...l never had issues then....lm Traktor guy for years and use the Traktor S8 because it meets my needs beyond what one can think of...l have tried other dj softwares but never felt comfortable as l feel with Traktor pro 3...With stems taking over in the DJ world, my S8 is like old wine ...l love it and ever hard any issues gor years now.....please help, l need pro 3 running

    , it has been difficult for me to gig with pro 2, it has no effects on the knob, no Ozone Maximizer plus love the beauty of Traktor pro 3 software ...l can't stand Serato at all..lm spoiled with Traktor wave forms and different modes

  • Kruter
    Kruter Member Posts: 2 Newcomer

    I fixed it! The problem was that Native Access could not get acess to my document file due to something in the availability was wrong. I ended up reeboting my laptop BUT it could possibly be fixed by changing availability in settings. Hope this helps others!

Back To Top