Kontrol S3 pads not lighting up

StuRS
StuRS Member Posts: 7 Sine

Hi all.

I am a new S3 user and returning to Traktor Pro 3 after initially using it a number of years ago with a Hercules 300.

Really liking the S3 overall and I had forgotten how powerful Traktor is, but….

Is it correct that only certain leds work when bus powered?

When running only usb bus power, buttons like, hot cues don’t light up, vu meters are very dim, volume quiet (louder when plugged in (volume is documented)

The lack of pads lighting up might be normal but I wasn’t expecting it, so it took me a little by surprise. Still trying to decide if this will bother me long term as it means a cheeky mains free mix is really off of the cards.

I have seen the posts about sound level and I am guessing this is when plugged in? I hadn’t actually noticed, but haven’t done a direct comparison with my DDJ400.

Thanks

Tagged:

Comments

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,119 admin

    Hi @StuRS would it be possible for you to try a different USB cable/power supply, as well as connecting it to a different computer to see if the issue persists?

  • StuRS
    StuRS Member Posts: 7 Sine

    No problem. I will try this tomorrow with a different USB cable and laptop to see if it makes any difference.

    thanks

  • StuRS
    StuRS Member Posts: 7 Sine
    edited March 24

    Good morning.

    I tried the S3 on another laptop this morning and used another cable.

    Interestingly the hotcues still don’t light up when using Traktor and USB bus power. Other buttons appear to function normally, eg. off when not in use. I added multiple hotcues and should have had blue pads, but nothing.

    On further testing, if I set a hotcue, or loop, the pad is not lit to indicate there is one set. However it does light up blue/green whilst pressing the pads to activate the hotcue/loop. Once released it turns off again. They work, just not visible until pressed, so hard to know if any are set.

    The hotcues do light up in VirtualDJ. So the software is communicating with the controller via the cable. I could visibly see the difference of colours, red, green, blue etc. Dimmer than mains power but were definitely lit up.

    Plugged in it lights up like a Christmas tree😁

    Does anyone else have this issue?

    is there a way to set an override as a quick fix? I had a look but couldn’t see a function re LEDs

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,119 admin
    edited March 25

    Using a power supply or USB cable shouldn't have an effect on the brightness of the LEDs. 🤔 Might be better if you contact our Traktor support directly so they can determine if it's a hardware issue or not. Keep up updated on how it goes.

  • Stevan
    Stevan MIDIMember Posts: 237 Saw

    I'm not an S3 user but I know that NI hardware has option in the preferences to set the ON and OFF state brightness. Maybe that's the case with your unit.

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,119 admin

    Brightness adjustment is not possible with S3 MK3 unfortunately. I believe it uses multi-color LEDs which need to be running at a fixed brightness level otherwise the colors would change.

    Speaking of which, are you actually using MK3 @StuRS?

  • StuRS
    StuRS Member Posts: 7 Sine
    edited March 24

    its this one.

    it’s weird that the hotcue pad leds work properly under mains power but not USB for Traktor. Both computers had fresh installs of Traktor Pro from My NI account, so are the latest version.

    I will give it one more try tonight, but otherwise support may be the best action.

    thanks

  • StuRS
    StuRS Member Posts: 7 Sine

    One thing I will try is running the setup wizard on startup. Got nothing to lose 👍

  • StuRS
    StuRS Member Posts: 7 Sine
    edited March 24

    Just to confirm hotcue issue

    mains on

    Mains off

    Not sure if the other button behaviour is normal between the two?

  • StuRS
    StuRS Member Posts: 7 Sine

    Not sure this can be a hardware issue?

    Virtual DJ mains on

    Mains off


  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,119 admin

    @StuRS I double-check with the Traktor team. Scrap my earlier comment about a USB cable not having an effect on the LED brightness. This article needs to be corrected:

    Comparing the TRAKTOR KONTROL S2 / S4 with the new TRAKTOR KONTROL S3

    The note at the bottom that says "Without a PSU connected, the LEDs are dimmed and the headphone volume is lower." actually applies to S3 as well. So confirming that what you're showing here is an expected behavior.

    More info about different output levels when connected to PSU comparing to just USB can be found here.

    Sorry for the wrong info in my previous comments. If you're looking to adjust the brightness, confirming that it's not possible with S3.

Back To Top