Brand new Guitar Rig 7 has same issues as Kontakt 7in Logic for M1 Macs

Mavros Member Posts: 33 Member

I just bought Guitar Rig 7. Great new options but incredible but true Native Instruments has build in the same bug in this plugin as in Kontakt 7. The simple entry of text in the search block for M1 Macs in Logic Pro X is impossible.

When you try to enter text in the search block all characters are interpreted as Logic key commands. Kontakt 7 has the same issue in its search block in the browser view since close to 3 years despite numerous updates!

Really incredible as the same search block works in Guitar Rig 6.

Is there still no work around for this.


  • Kymeia
    Kymeia Member Posts: 2,695 Expert
    edited September 28

    This is what worked for me. I couldn't replicate this at first on My M1 Max until I resized the window in the plugin version in Logic. Then suddenly I got the same problem and also with Komplete Kontrol and Kontakt 7. This persisted even between reboots. However I found if I open the standalone app version of these plugins and return them to their normal size with Logic closed, then set the zoom level I want to use, this seems to also reset their behaviour in Logic and now I can enter text again. So if you need to resize do it outside Logic. I think the problem is with how Logic remember windows states for these plugins between sessions, it steals focus from the plugin to Logic. Resetting the size outside Logic forces Logic to flush whatever it is using to remember those states. I no longer have the bug as long as I make sure I do no resizing in Logic.

  • Mavros
    Mavros Member Posts: 33 Member

    Hi Kymeia, Thanks for your answer.

    With Guitar Rig Pro 7 I did some more tests and the behaviour is as follows. You open GR7 for the first time. You can enter text in the search field. You press the button with three vertical lines (///) to go to the new chain configuration window and back to the browser by pressing the /// button again and the text search box does not work anymore and entry is interpreted as a Logic key commands. When you close GR7 and open it again the text search block works again. So this is a work around for the bug.

    I also did this test in Kontakt with the little search box in the "conventional" K6 browser. The same behaviour. It work the first time you open Kontakt. You switch to the new browser with the /// button where the search box never works and when go back by pressing the /// again the old browser search box also produces key commands instead of characters. When you then close and open Kontakt in Logic the old browser text search works again. So the string of actions initiated by pressing the /// button causes the issue in both plugins.

    I read your post in the Kontakt text entry post on resizing. I have opened Kontakt 7 with Logic closed. Resized it to its smallest size 75% using the zoom tab (not the sizing button in the bottom right) and also resized the Interface in the settings. When I open Logic Kontakt 7 is the same size as when I left it 100% and the text enter issue persists. The same with 100%.

    I did some further tests e.g. I resized Kontakt to the smallest size 75% in Logic. Saved the filed, closed Logic and opened it again. Logic shows Kontakt again as 100% zoomed. So the 75% of the last sizing is not saved even if you save the file. In GR7 the zoom size is saved correctly with the project. Kontakt always refers back to 100% and what might be an issue the size at 100% is not the same as in Kontakt standalone. It is higher.

    I also rescanned Kontakt 7 in the plugin manager in Logic after having made the changes in the stand alone. It is validated but there are a huge number of warnings in the process and also some errors at the open time tests (cold and warm shows missing files) but it still pass after a number of checks failed or produced warnings.

    So no success this way with Kontakt unfortunately .

Back To Top