Please be advised that due to scheduled infrastructure maintenance, we anticipate downtimes for the Native Instruments websites and Native Access on February 28, 2024 starting at 06:00 CET. For more details, click here.

S61 Mk2 browser and plug in button don't work

tonirom Member Posts: 2 Newcomer

Hi, I have a problem with my S61 Mk2, I was trying to integrate it with Logic Pro X but my browser and plug in buttons don't seem to work, also in mixer mode my logic tracks do not appear in the display. Can someone help with this? Thank you very much.


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod
    edited September 2023

    @tonirom Is everything functional in Komplete Kontrol in standalone? Make sure to give full disk access to both Logic and Komplete Kontrol: How to Enable Full Disk Access on macOS

    Do you have any other MIDI devices or control surfaces set up in Logic?

    If the full disk access thing did not help you can also reset the Komplete Kontrol integration by deleting this file:

    Macintosh HD -> Users -> *Your User Name* -> Library -> Preferences ->

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:

  • tonirom
    tonirom Member Posts: 2 Newcomer

    Hello, I have followed your instructions. Given full access and deleted the suggested file. Browser and plug in work fine. I still do not get the logic mixer channels to appear in the S61 mk2 display after I press the mixer button? Why?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod

    Usually deleting this file fixes the issue. Does it also happen in Rosetta mode?

    You could also try deleting this file:

    Delete the Logic Pro PLIST file

    1. In Logic Pro, note any custom preference settings that you’ve made, and save any custom key commands that you've created
    2. Quit Logic Pro.
    3. In the Finder, choose Go > Go to Folder.
    4. Enter ~/Library/Preferences, then click Go.
    5. Remove the "" file from the Preferences folder. 
    6. If you upgraded from Logic 9 or earlier to Logic Pro, also remove the "" file. 
    7. Restart your Mac.

Back To Top