Traktor 3 behaves strange

Fatalfelix Member Posts: 3 Member

I have a MacBook Pro from 2014 and a S4 MK3 with Traktor 3 software (latest update 3.9.0). Since a while the system behaves strange.

When I start djing everything seems fine, but after a while I hear small pops in the sound. Not continuous, but like one pop every 10-15 minutes. Sometimes it also looks like the wave pattern freezes for a second when I hear the pop. After this the audio output changes sometimes which is very annoying.

For example, my headphone volume becomes suddenly very low or stops working, and other times there is clipping in the sound. Once the speed of the sound increased out of nothing and I also lost notes and cuepoints randomly. Very strange and not nice at all when playing live. When I reboot everything works fine again for a while.

Is this a soundcard issue, an OS problem or is it something within Traktor?


  • 2,8ghz quadcore i7
  • 16gb ram
  • Intel Iris Pro 1536
  • 1tb ssd
  • OS: Big Sur 11.7.9

latency of Traktor is set on 512. Laptop should handle this without problems. Load bar is also almost empty when playing music so this looks ok.


  • digisun
    digisun Member Posts: 8 Member

    How does it work if you go step back in Traktor software?

    Have you got Timemachine for your backups running?

  • c0nsul
    c0nsul Member Posts: 291 Pro

    I think your Mac should handle Traktor fine. Do these dropouts and issues also occur, when you use Traktor without your controller?

    Please try using Traktor with the Mac´s internal audio device and headphones plugged into your computer and report back.

  • Stevan
    Stevan Member Posts: 1,512 Expert

    I noticed similar problem with PC from that age. (4th gen Intel)

    Problem was solved by disabling the Limiter. Hope it helps on your mashine.

  • Fatalfelix
    Fatalfelix Member Posts: 3 Member

    Thanks for your help!

    I tried a couple of things:

    • Went one step back in time with Traktor
    • Limiter is of now
    • Lowered the channel gains
    • Changed some settings on my Mac: Auto-sleep was on including an option to start automatic updating or back ups when screen turns off. Maybe this was conflicting as well.

    Lets see in the next days if the problems are still there.

    Played music without the controller as well. This works fine. Or at least, I did not experience problems yesterday. The balance of the sound is even better. My S4 gives the left channel like 10% more volume compared to the right channel. Never figured out why. On the laptop the sound is equally balanced.

Back To Top