M1 MacBook & Start/Stop Transport Controls in Studio Drummer

Options
William Henley
William Henley Member Posts: 2 Member

Several years ago EvilDragon was kind enough to enlighten me as to what change to make in the KSP Script in order to Start and Stop a Groove from my MIDI Controller. I made the change, it worked perfectly and I've used it ever since.

Now I'm in the process of migrating from PC Windows 11 to MacOS on an M1 MacBook Pro and not only can I not find my notes on the change, Kontakt crashed on my PC several months ago so I can no longer perform the Start/Stop on either system.

If Evil Dragon is still around or another member has the answer it would be very much appreciated.

Best Regards,

Bill

Best Answer

  • EvilDragon
    EvilDragon Moderator Posts: 1,023 mod
    Answer ✓
    Options

    You need to edit the script so that the start/stop button is a ui_switch instead of a ui_button. Then you will be able to MIDI learn it.

    To do this, you need to go to Script Editor, select the Grooves tab, open the Edit view, then in Apply from... menu choose Editor/Patch.

    Then you search for line declare ui_button $play and modify accordingly. You need to do this for each NKI separately.

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,314 mod
    Options

    @William Henley Are the crashes related to the script, in your opinion? Have you tried those steps? KONTAKT Crashes

    For the rest, maybe @EvilDragon can help out!

  • EvilDragon
    EvilDragon Moderator Posts: 1,023 mod
    Answer ✓
    Options

    You need to edit the script so that the start/stop button is a ui_switch instead of a ui_button. Then you will be able to MIDI learn it.

    To do this, you need to go to Script Editor, select the Grooves tab, open the Edit view, then in Apply from... menu choose Editor/Patch.

    Then you search for line declare ui_button $play and modify accordingly. You need to do this for each NKI separately.

  • William Henley
    William Henley Member Posts: 2 Member
    Options

    Thank you for the reply. I apologize for the late response. Having some health issues at the moment.

    Thanks again,

    Bill

Back To Top