Issues with KK M32

bch
bch Member Posts: 2 Newcomer
edited September 1 in Komplete Kontrol

Scenario: I have no audio apps open or anything that is using the keyboard, or any other NI hardware connected.

When connecting the keyboard says it's in MIDI mode - but not the "normal" MIDI mode because transport buttons etc. lights up (see attached photo).

I can not use the keyboard in audio apps because it's "already in use by another program".

The only thing that lets me go back to MIDI mode is opening the KK software and click the MIDI icon, but as soon as I close KK, it goes back to the "colorful MIDI mode".

I can close the NIHostIntegrationAgent service and reconnect the keyboard and it goes to normal MIDI mode but then it doesn't work at all.

Everything is up to date, hardware and software-wise. I have tried to reinstall Native Access 2 and Komplete Kontrol.


Please help, thanks! :-)

Best Answer

Answers

  • PoorFellow
    PoorFellow Member Posts: 361 Pro
    edited July 7

    First of all , if you ask for help then please always state your platform : MAC or PC ? and the specifics of the OS used..

    You come across as a Windows user , so I will go with that...

    IMPORTANT : prior to any computer tinkering then please at least make a Restore Point , and prior to tinkering with registry take a back up of the registry. Also generally it's always advisable to backup the whole system drive once in a while or at least if you got something that you do not want to loose if you mess up anything !

    Try this : once again uninstall Native Access 2 and Komplete Kontrol

    Then download and use NI Uninstall RegTool_64bit : https://support.native-instruments.com/hc/en-us/articles/115003509269-Fixing-Software-Update-Installation-Issues-Windows-

    then use that tool to remove anything starting with Komplete Kontrol and the NIHostIntegrationAgent , NTKDaemon , M32 and ControllerSettings....

    Then restart computer and when OS fully started then open Task Manager and check that you got rid of the NIHostIntegrationAgent and the NTKDaemon processes , if you didn't get rid of them then , read my post starting with Quote : "Cant upgrade to the Access 2" : https://community.native-instruments.com/discussion/comment/82995#Comment_82995 from section "how I did myself" to get rid of them.

    Since that you complain about MIDI issues then , just in case, I also suggests that you disconnect the M32 and then use the "KORG MIDI Driver Uninstaller" to take a look at MIDI drivers in your system and get rid of previous M32 and rid of anything that you do not need (especially if you have too many drivers installed) , Downloads are found here : https://www.korg.com/us/support/download/product/1/285/ and how to use here : https://www.audiomentor.com/audioproduction/daw-unable-detect-midi-controller-windows/

    Then when you are confident that you got rid of all the remnants of old installations then reboot computer and try reinstalling the Native Access 2 (run as administrator !) and Komplete Kontrol to see if all your effort helped !

  • JesterMgee
    JesterMgee Member Posts: 2,099 Expert
    edited July 9

    Stupid question but have you simply tried restarting your PC and testing again? Kind of seems like something has grabbed it. Also, a good idea is to fill your system details into your account profile so people know what you are using (because it's a key piece of info people always seem to leave out when asking for help).

    Before embarking on a rather complicated scenario of uninstalliung MIDI drivers etc, i'd suggest first to see if things are installed correctly to begin with, that is something knowing if you are on mac or PC would help... Need to confirm if all MIDI ports are listed and possibly, just a reinstall of the driver is required.

  • bch
    bch Member Posts: 2 Newcomer

    Thanks for your long post. I did everything you suggested but the problem remains the same.

    It's like the keyboard is used by some other process or is in a wrong state when in MIDI mode.

    When I open Bitwig: MIDI Output Error. Could not open MIDI output...

    In the KOMPLETE KONTROL MIDI Output settings I cannot turn on the KOMPLETE KONTROL M32 MIDI port. The checkmark won't check.

    Thanks.

  • PoorFellow
    PoorFellow Member Posts: 361 Pro
    edited July 10

    The only thing I can think of at this stage would be to direct you to this post , scroll down to where it says "Best Answer" :

    https://community.native-instruments.com/discussion/5457/how-to-solve-a-malfunctioning-komplete-kontrol-s88/comment#31056


    In that specific case then something called BMidi could either caused the issue or helped solve it , or both.  Anyway , it appears as if somethings can cause important N.I: components to not work as intended.


    BMidi apparently can be used to help make some apps see some midi devices , but I don't know if it in your case might just make things worse , so at least make a system restore point to revert to prior to trying to play with that ! (?) : BMidi : https://www.bome.com/products/bmidi


    Anyway , otherwise you must contact support and make them help you , but from how it looks at the other post then it's terrible ordeal that even could involve a suggestion from support that one re-install Windows... To which I would like to add that if you want to try that avenue then maybe you should backup your whole computer and especially system drive prior to trying that...

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,045 mod
    edited July 17

    Hey @bch If you open Komplete Kontrol in standalone, is everything working as expected? Can you post a screenshot of your MIDI preferences, input & output?

    Maybe this will be helpful: https://gearspace.com/board/music-computers/753800-midi-port-use-another-application.html

    Also godd that you mention Bitwig, I've seen a couple of other posts regarding the MIDI output Error. I believe in one of them, the fix was to uninstall the NI Accessibility Helper, is it installed on your system?

    In another post the user mentioned this issue was fixed witht he latest Bitwig 5 beta. What version of Bitwig are you using?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,045 mod

    @bch Any update on your issue? Do you still need help?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,045 mod
    Answer ✓

    No news from you for a while. We’re closing this thread now. If you still need assistance on that topic, please get in touch here: http://bit.ly/NIsupport_KKontrol

This discussion has been closed.
Back To Top