Kontrol S2 MK3 - Filter

rob81
rob81 Member Posts: 4 Newcomer

Hi,

is there any way of switching back to using the effects knob as a filter once you have pressed one of the 4 effects buttons on the S2 MK3? You can allocate 4 effects and a filter function to the knob, see below. But it seems to me that once you’ve pressed one of the effects buttons you can’t switch it back to a filter?


Any help or tips on this would be great.

Thank you

Answers

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,525 mod

    What happens when you press the same button a second time? What does the S2MK3 manual say?

  • rob81
    rob81 Member Posts: 4 Newcomer

    It just activates and deactivates the effect that’s assigned to that button. Once you press one of the four dedicated effects buttons it seems there no going back using the filter unless you use the trackpad / mouse on the laptop and click on the drop down menu and select filter.

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,525 mod
    edited June 2023

    You can overmap the buttons, so that, when holding shift, any MixerFX button press will reset both deck's MixerFX to Filter, if you know how to do it.

    As a quickfix, set one of your 4 MixerFX to Filter. You will have only 3 to play with this way, but you will have Filter on a single press of a button at any time.


  • rob81
    rob81 Member Posts: 4 Newcomer

    Thank you. I saw that you could set one of the 4 buttons as a filter which is what I’ve been doing so far. I’ve never had a go at remapping but I’ll have a look and see if I can do it 👍🏻

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,525 mod
    edited June 2023

    I will cook one up for you and post it here, so you have something to base future mappings on.

    EDIT: Took only a minute.

    Go into controller manager. In the device dropdown list, delete the standard S2MK3 mapping. Right below it is the button 'Add...'. Press it and select the uploaded file. Make sure the controller is selected at the top right IN/OUT dropdown menu.

    Note: the assignments to the SHIFT buttons have the box 'override' unchecked, so that the shift button's original functions are still working, in case you want to tinker with the mapping.

    Enjoy. 🦋

  • rob81
    rob81 Member Posts: 4 Newcomer

    Sorry I’ve only just seen this. Thank you so much, I’ll give it a go 👍🏻

Back To Top