How can I install Traktor Scratch Pro 2 on my mac m1 OS 12.4

jlm1219
jlm1219 Member Posts: 2 Newcomer

Hi all,


I cant seem to find the TSP2 download, I own the product and have serial #s, but its not showing up in Native Access.

Best Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,789 mod
    Answer ✓

    Hey @jlm1219 Traktor Pro 2 was discontinued and is not compatible with newer operating systems.

  • Stevan
    Stevan Member Posts: 1,295 Expert
    Answer ✓

    Additionally, beware that Intel mac with Catalina and newer also cannot support Pro 2.

    Your best bet is to Upgrade to Pro 3 on your M1. Or have Mojave installed on some Intel mac to continue using the Pro 2.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,789 mod
    Answer ✓

    You can still use Traktor Pro 2 on a compatible operating system.

Answers

Back To Top