nihostintegrationagent not loading on PC startup

keefycal
keefycal Member Posts: 22 Member

Hi Forum

For many months (possibly starting following a Windows update) the Services prog. nihostintegrationagent has not loaded automatically on startup - despite appearing to be 'running/automatic'. Consequently, my DAW does not appear in my Cubase 'Startup' box as expected. My work around is to go to 'Services' and restart the prog. manually - usually taking 3+ attempts. It has taken me a long time to get this far. Reinstalling KK does not fix it.

I have exchanged 50+ emails with NI tech. but have had no resolution. It is if another prog. ie AVG is blocking it, but I have tried uninstalling all the possible culprits and still it does not work properly. (I made a video clip to show my issue but the MP4 ext. is not permitted on the att. below).

Any ideas would be gratefully recieved.

Keith

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,884 mod
    Answer ✓

    Hey Keith! It's a long standing issue indeed. Hopefully my colleagues get to the bottom of it. Do you have any kind of property cleaning utility or Windows optimization, tuning up program? Notes on Using Registry or Property List Cleaning Utilities

    We've seen those creating quite some damage, sometimes not reversible, leading to a full Windows reinstall.

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,470 Expert

    First suggestion, get rid of AVG.

    If you are on Windows 10 or 11 then you just do not need AVG or any other "virus scanner". These often create more problems than they are worth nowdays and the inbuiilt Windows protection and staying off those dodgy adult and "free software" sites is all you need to worry about.

    Quite possibly AVG is killing that process for some unknown reason and it's the first thing I would remove and see if it fixes the issue.

    Videos can be uploaded to any file share location, I just use a Google Drive or Dropbox account for videos and share the link.

  • keefycal
    keefycal Member Posts: 22 Member

    Hi Jester

    Many thanks for your response.

    Your suggestion makes good sense, but I have tried uninstalling my AVG and it didn't make any difference.

    Cheers

    Keith

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,884 mod
    Answer ✓

    Hey Keith! It's a long standing issue indeed. Hopefully my colleagues get to the bottom of it. Do you have any kind of property cleaning utility or Windows optimization, tuning up program? Notes on Using Registry or Property List Cleaning Utilities

    We've seen those creating quite some damage, sometimes not reversible, leading to a full Windows reinstall.

  • keefycal
    keefycal Member Posts: 22 Member

    Hi Jeremy

    Thanks for your response. I do have some AVG potential bad boys on my Windows 10 sytem. Uninstalling them has not made any difference, but if my only resolution is to reinstall Windows, I think I will continue as at present - activating the NIhost.... every time I do a session.

    Cheers

    Keith

    I

Back To Top