MK3 Not listed in software

Options
Raztheory
Raztheory Member Posts: 8 Member
edited March 2023 in Maschine

So today, I go into my studio and turn on my setup, the MK3 controller stays on the screen saver, and is "Grayed Out" on screen in the "Controller" drop down list within the software. The device works perfectly in my old computer, so its not a hardware issue.Soes anyone have the fix for this,I am using Windows 10. I saw a YouTube video for the perfect fix, but it was for "Apple" :(




https://www.youtube.com/watch?v=8ErFx9i6wCc&t=185s

Best Answer

  • Uwe303
    Uwe303 Moderator Posts: 3,296 mod
    Answer ✓
    Options

    If you have checked all that, including the harwareagend and harwareservice running + a maschine studio is also not recognized i would reinstall windows, finding the issue can take forever, if you ever will find it.

Answers

  • Uwe303
    Uwe303 Moderator Posts: 3,296 mod
    Options

    Hello,

    on windows, disconnect maschine - open device manager - set view, show all devices - then delete all maschine related stuff and if asked to delete the driver say yes - reinstall drivers - then reconnect maschine after all steps!!

  • Raztheory
    Raztheory Member Posts: 8 Member
    Options

    I tried this and I still have the same result. I sent in a request to the NI team and hopefully they will have an answer soon.

    P.S- I like your music

  • Raztheory
    Raztheory Member Posts: 8 Member
    edited March 2023
    Options

    Yes, I have checked those items, followed the instructions, and have taken several steps to resolve.

    1. I removed the drivers, unplugged the unit and reinstalled the drivers.
    2. I tried the hardware on another computer and it worked perfectly.
    3. I used different USB cables.
    4. I removed recent "Windows" updates.
    5. I reset the computer to last known restoral point.
    6. I hooked up a "Maschine Studio" unit and it also was not recognized.
    7. On occasion have experienced a system crash and followed the steps to resolve those.
    • It crashes every time I turn it on now.

    *At this time I am at my wits end.I have projects to complete and no more ideas.

  • Uwe303
    Uwe303 Moderator Posts: 3,296 mod
    Answer ✓
    Options

    If you have checked all that, including the harwareagend and harwareservice running + a maschine studio is also not recognized i would reinstall windows, finding the issue can take forever, if you ever will find it.

  • Raztheory
    Raztheory Member Posts: 8 Member
    Options

    You may be right because the " NI Integration Host" under the service tab is not even showing up, and when it does,it won't allow me to restart it.

  • Uwe303
    Uwe303 Moderator Posts: 3,296 mod
    edited March 2023
    Options

    Then there is the issue, do you have a windows admin account? Have you tried to start the driver install as administrator?

  • Raztheory
    Raztheory Member Posts: 8 Member
    edited March 2023
    Options

    It usually loads the drive automatically, and sometimes I reload it from N.I Access. I just reloaded the drivers from N.I Access as an admin.

  • Uwe303
    Uwe303 Moderator Posts: 3,296 mod
    Options

    you right click on the exe file and select "start as administrator", and it also can be the case that the ransomware protection prevents the driver from install, you could deactivate it while installing native stuff, on my computer i normally get a prompt on some first installs or program starts and it leads me to the ransomware protection there i set it to allow and then it works - all my native stuff is listed there:

    https://support.microsoft.com/en-us/windows/allow-an-app-to-access-controlled-folders-b5b6627a-b008-2ca2-7931-7e51e912b034

  • Uwe303
    Uwe303 Moderator Posts: 3,296 mod
    Options

    as an example you see here some native stuff, there is more in that list.

  • Raztheory
    Raztheory Member Posts: 8 Member
    Options

    I did a Windows reset and it worked! Thanks for all your help.

Back To Top