Admin rights and Drag and drop from desktop to Traktor deck

Have Reinstalled Traktor 2 pro on a new windows 10 pc. And it has been a nightmare.

I can only use traktor as administrator. Although login has full Admin rights.

Now traktor is working. I am unable to drag and drop files from desktop or any windows folder directly into a traktor deck.

The only way to so is to navigate via the traktor explorer tree.

This exact same software worked faultlessly on old pc. Also windows 10

What have I missed?Any ideas?Installed several times via Native access. But can not get past initialize screen unless I open traktor as Admin.

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,474 Expert

    You will prob need to resolve the issue somehow on why you cannot launch under your user privilege normally since elevating software to admin will then make anything that is not running in admin unable to talk to it (including the OS) so DnD wont work, this is the case with all software.

    If it is a new system, have you tried to disable all the extra stuff like UAC?

  • zephry
    zephry Member Posts: 560 Pro

    I found this in an old post on Microsoft.

    If you are sure you are set as Administrator and logged into a Microsoft account.

    Then here is something to try...


    1. Open the properties of the main User Profile folder where the files are located (such as Documents, Pictures, etc.). For example: if your user profile name is computer then the navigation path will be C:\Users\computer. You can open the properties of a particular folder by Right-clicking on it and select Properties from context menu.
    2. Go to the Security tab and click Advanced.
    3. Check the box at the bottom of this window. It is labeled "Replace all child object permissions with inheritable permissions from this object" and then click Ok.


  • shoustonnz@gmail.com
    [email protected] Member Posts: 5 Member

    I am out of the office for a few he next 4 days. I will look at both of these on Wednesday.

    One of our network guys have suggested a very similar solution to this as well.

    I will share results. ASAP.

  • diegoolei
    diegoolei Member Posts: 2 Newcomer

    Hi! I´ve founded a bypass solution for this problem, you just have to run traktor 2 pro with the compatibility tool, using the windows 8 option.

    For some reason, it doesnt work just by saving that configuration, you have to run it with the tool every time for this to work (thats why i call it a bypass)

    Hope it works for you,

    please inform if you found a more persistent solution

  • diegoolei
    diegoolei Member Posts: 2 Newcomer

    Update: Just discovered the ultimate solution, to the executable traktor file in the root folder (right click < go to root folder) instead of windows 8 compatibility use windows 7. You also need to deactivate full screen optimization.

    You will need to delete the direct access file in the desktop and create a new one with those parameters modified.

    Good luck, hope it works for you

  • shoustonnz@gmail.com
    [email protected] Member Posts: 5 Member

    We have actually worked out our issue.

    And must admit it was way above my paygrade.

    Apparently our PC's at work are so tied down in Security that we had to alter "The IO"

    Not the audio IO, but somethinh to do with the shortcuts and their rights.

    But it all works now as expected, and without the need to run in Admin mode, and we can drag and drop.

Back To Top