Battery 4, Maschine and Komplete Kontrol not showing all libraries

This discussion was created from comments split from: Native Access 2 (Intel Mac) Application Location setting Error Flag in Preferences.

Comments

  • David!!!
    David!!! Member Posts: 4 Member

    @Jeremy_NI Thank you for your answer. I finally managed to make it work yesterday but now I have another issue that drives me nuts :)

    All the libraries in Maschine and Battery are not showing up. I tried to reinstall, rescan but nothing happens.

    And even when I try to happen a kit in battery I can see the kits in the folder but they are greyed out and I can not click on them to open them... Please help me!


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,935 mod

    Hey @David!!! I created this thread from your last post, as the subject is now different.

    So make sure that Battery 4, Maschine and Komplete Kontrol all have Full Disk Access: How to Enable Full Disk Access on macOS

    Then you would need to reset the database for Battery, Maschine and Komplete Kontrol.

    Reinitialize the KOMPLETE KONTROL Database

    1. Go to the following location on your computer:
    2. Macintosh HD > Users > *Your User Name* > Library > Application Support > Native Instruments
    3. Note: The User Library folder is hidden. See this article for instructions to access hidden macOS folders.
    4. Search through the Native Instruments folder at this location to find the KOMPLETE KONTROL folder.
    5. Delete only the KOMPLETE KONTROL folder found here.
    6. Note: Deleting other NI product folders could result in unexpected behavior with other applications.
    7. Reboot your computer and reopen the KOMPLETE KONTROL software to check that the issue has been resolved.

    Repeat with Battery 4 and Maschine.

    That should be fixed now.

Back To Top