Mapping: Mixtour Reloop + Traktor Pro 3

Hello peeps. I have a question related to the mapping: we uploaded the mapping file from the official website for Mixtour into the Traktor Pro 3. The connection worked but now the mapping of the buttons doesn't work as it should. For example clicking on the device button Play Deck A works fine, but when pressing Play Deck B it launches the song on Deck A again. Also clicking on "Headphone" doesn't make it to listen to in the headphones. Any ideas how to solve this?? Thank youuu

Answers

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,465 Expert

    If you have previous experience with mapping devices to Traktor Pro, have a look at the mapping details. Or upload the file here so we can have a good look and point out the assignments in need of improvement. In addition please post other defects of the mapping as well, if there are any.

  • Ice_DeeDee
    Ice_DeeDee Member Posts: 5 Member
    edited September 2023

    Hi! Thanks for the prompt answer! I don't have much experience with the mapping, so I wouldn't feet capable to analyse it - and we are time pressured due to an upcoming gig. The mapping file is the one from the official website of Mixtour, I have attached it here.

    I have also tried with another mapping file and the issues were exactly the same. I am attaching that one also, maybe it can help.


    Issues:

    1. The play button on deck B launches play on deck A
    2. Upload of songs into newly created playlist folder on Traktor: The "shift" for multiple select doesn't work. And adding songs one by one doesn't work either.
    3. The headphones button doesn't work.

    For now these are all the issues.. Thanks again!


  • Stevan
    Stevan Member Posts: 1,512 Expert

    You may want to check for firmware update first since multiple mappings are issue.

  • Stevan
    Stevan Member Posts: 1,512 Expert

    Monitor cue is in there, same midi note and different channels. Looks good.

  • Ice_DeeDee
    Ice_DeeDee Member Posts: 5 Member

    Thanks! We also did the firmware update and it didn't solve it.

  • Stevan
    Stevan Member Posts: 1,512 Expert
    edited September 2023

    And SHIFT + Volume Fader? does that start a deck.

    BTW the play command is also looking good so these are config or hardware issues.

  • c0nsul
    c0nsul Member Posts: 290 Pro
    edited September 2023

    The mappings you posted, both work in different ways in terms of "Device Focus". Maybe installing both of them causes conflicts.

    I would suggest to delete every single mapping first to troubleshoot. After deleting, close Traktor and turn your controller off and on again.

    Re-start Traktor again with the controller connected and switched on.

    After restart, import the official mapping from the mixtour webpage (to make sure we are all talking about the same mapping) with the big import button on the bottom of the preferences window. This official mapping contains 3 (sub) mappings each for Mixer, DeckA and DeckB.

    Then go to preferences -> Controller Manager:

    On top it says "Device", make sure there are 3 mappings imported (Mixtour Mixer, Mixtour DeckA and Mixtour DeckB).

    Verify that each mappings has its "In-Port" and "Out-Port" set correctly to your controller (Don't use "All Ports", choose your controller). Also, "Device Focus" should be set correctly for each mapping. Mixer mapping has to be set to "Focus", Deck A mapping to "Deck A", Deck B mapping to "Deck B".


    If your controller still doesn't work, we can troubleshoot if it is sending correct midi notes:

    In "Controller Manager" select "Mixtour DeckB" mapping, scroll through "Assignment Table" and search for "Play/Pause (Deck Common)". There are 3 commands with this name. Highlight the one with "Toggle" in it.

    Now, under the "Assignment Table" it says "Device Mapping" and you see the midi note "ch02.Note.C0". Next to the note on the right side is a button called "Reset". Please reset that note and then click (activate) the "Learn" button on the left side. Now, on your controller press the play button for deck B and then deactivate "Learn" by clicking it again. What midi note is shown now?

  • Ice_DeeDee
    Ice_DeeDee Member Posts: 5 Member

    Hi c0nsul, we did the exact same thing as you indicate. I'll try the last bit and get back to you. Thank you!

  • c0nsul
    c0nsul Member Posts: 290 Pro

    Yeah, let us know the outcome, so we can narrow down the issue.

  • Ice_DeeDee
    Ice_DeeDee Member Posts: 5 Member

    Hi all, apologies for the late reply. The DJ that I was helping decided to buy another device in the meantime and the software works well on that one, so he decided to stop troubleshooting the reloop.

    Thanks again everyone for your prompt answers and also for following up. I must say there is high quality in this forum, in terms of feeling the support of the crowd, the "village".

    Best,

    Diana

  • UncleBetty
    UncleBetty Member Posts: 1 Member

    When I loaded the mapping the "MIXTOUR Deck B" mapping had a device target set to "Deck A" (Whooops), so just switched it to "Deck B" and all seems to be fine

Back To Top