"saved with newer version of reaktor" — how to access legacy ensembles?

Options
Timbeaux
Timbeaux Member Posts: 2 Newcomer
edited May 2022 in Reaktor

hi @ni.reactors—

I am currently revisiting and cleaning up old Ableton sets and some Reaktor5 instances complain they cannot find the ensemble in question. Once pointed to the correct ensemble, it then complains that the latter has been saved with a "newer version of reaktor" and I must "update [my] software". Problem here is, I can swap the AU for Reaktor 6 but all the settings/params from the old ensemble are lost in this case. How can I recover old ensembles? Can I downgrade some packs in use (i.e. Maschine packs now using Reaktor 6 instead of 5) to allow the presets to load again? Reaktor doesn't provide me with a guide as to which snapshot was used in the old version. This way I cannot recover the ensembles nor do I have an intuition.

Any hint is highly appreciated!

Tx

Comments

  • Paule
    Paule Member Posts: 1,327 Expert
    Options

    If your OS don't supports R5 anymore you can't exchange your instances with R6.

    It's not a problem by Reaktor it's your OS only.

  • deppe
    deppe Member Posts: 1 Newcomer
    Options

    Above answer is not correct. While i can't answer the question, i can tell you Reaktor 5 works beautiful on my windows 10 but projects saved with Reaktor 6 always break exactly as questioner described. So in practice, i see Reaktor 6 as not supported by Windows and consequently, I never use Reaktor 6 anymore and that solved the project loading issues.

  • Paule
    Paule Member Posts: 1,327 Expert
    edited May 2022
    Options

    Mac OS is very different to R5. So the answer is correct.

    Win OS works parallel R5/R6.

    @deppe

    Above answer is not correct. While i can't answer the question, i can tell […]

    if you can't answer the question you can't write „Above answer is not correct“

  • Timbeaux
    Timbeaux Member Posts: 2 Newcomer
    Options

    The above answer may be correct, however, and in truth, my OS (macOS 10.14 Mojave) does indeed support Reaktor 5 (an 6 in parallel), I can load the old version without any issues.

    Since Reaktor5 does open but complains the ensemble in question has been »saved with a newer version of Reaktor!«, and without any further guidance I can only speculate that some Maschine pack—which was used earlier—must have been updated to R6 by Native Access or my humble self (?), and thus cannot be loaded by R5 anymore. It is thus not an OS problem, but a software problem, and guidance would be wonderful.

  • Paule
    Paule Member Posts: 1,327 Expert
    Options

    I don't own Maschine but my ens saved in a project comes ever from another path than the installed. So in this location is no automatic update and projects are fine.

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,702 admin
    Options

    @EvilDragon Perhaps you know an answer to this question?

  • EvilDragon
    EvilDragon Moderator Posts: 1,023 mod
    Options

    Hmmm, unfortunately no idea. If replacing the AU .component file of R5 with the one from R6 doesn't help or work, not much else that can be done AFAIK.

Back To Top