Maschine Plus 1.4.4 - Long time when shutting down.

1234579

Answers

  • Pollip
    Pollip Member Posts: 11 Member

    Beat me - but despite the built in bugs, M+ runs much more stable now....

  • D-One
    D-One Moderator Posts: 2,689 mod

    Oh, OK. The Recent list is most likely saved on shutdown, since shutdown is broken it's not saved. ETA on this sort of thing is usually a vague "soon", from past experience it's ussually 2-3 weeks after the problematic update so probably any day now but I have no official info on this.

    I doubt NI will put out a public way to revert back, especially if the bugfix update is to be released soon.

  • JayTee303
    JayTee303 Member Posts: 28 Member

    One of my bugs was that i probably pulled out the plug before m+shutted down completely. Since auto backup was on every time i booted i got the message do you want "date and time of the project" restored with the option discard/restore. No matter what i chose, every time i booted up it was the same. I tried discard, restore, save it and start a new song and save that again etc but no go. The only solution is to turn auto backup off, was the only way to fix it. Suppose i get this again (did a whole reset before finding this tread and realizing it was a bug, lost 5 hours and got Tachycardia from the frustration lol , thx ni...), because of the long bootup (30 sec) and long shutdown (min 1 minute) where are these files located? Deleting them should get rid of it. Downside is that the backup feature doesn't ´t work. 2 ps:1 is there a way to set a template, first thing i need to do is change full velocity from 100 to 127, any way to change that? If i could make a template that would solve it. Also with the update something is wrong with external usb drives.. if you go into settings and shift with library, somtimes the usb wasn´t recognised, and i had to remove it insert and rescan. Same as booting up/ down, rescanning took extremely long. Its a 512 gb drive with about 150 free, and took about 2 hours to rescan instead of the 15 minutes! I also noticed that the circle indicating rescanning wasn´t smooth at all like normally, but jerky and sometimes stopped for a few minutes. I think theres a link between the booting up and slow rescanning of drives. Guess i´m gonna return to the prev version, as the new features arent worth the hastle. There are lots of smaller bugs too, loading monark used to be 20% for the first instance, now itns in the 30%. The switching from idea to song had also weird glitter. Hope this all gets fixed soon, because with standalone hardware you have much less troubles than with a pc, or so they say...

  • Pollip
    Pollip Member Posts: 11 Member
    edited December 2022

    Don't get me wrong - i do not regret the purchase of M+ for one second. Just expecting NI to locate resources for continous further software development and the willingness to Listen to customer's voice.

    I.e. - does anyone know a single product in the world with built in bluetooth, but disabled from scratch?

  • D-One
    D-One Moderator Posts: 2,689 mod
    edited December 2022

    @JayTee303 asked:

    where are these files located?

    What files?

    is there a way to set a template?

    Do you mean automatically loading a template project on boot? Nope, only possible on MAS desktop. It might not be a good idea to auto-load projects on a device not so stable, if the project ever has an issue it might stop you from booting. I'd just make a template project with a name that starts with "AA" or "!" so it shows at the top of the list then use a computer to set it as read-only so I never accidentally save over it, not sure how this would affect auto-save tho.

    first thing i need to do is change full velocity from 100 to 127, any way to change that?

    Go to Pad Mode and navigate to the 2nd Page.

    Hope this all gets fixed soon, because with standalone hardware you have much less troubles than with a pc, or so they say...

    People just repeat that because others said it, it holds a lot of truth for older devices but even those had bugs too.

    An M+ is miles apart from standalones from back in the day that had 2mb of firmware, fixing a bug on 600mb of data is not as easy, not an excuse but just saying... your M+ is much more like a normal computer than an old-school low res screen standalone.

  • JayTee303
    JayTee303 Member Posts: 28 Member

    asked:

    where are these files located?

    What files?

    To clarify I’m talking about m+ in standalone. It’s the new backup feature, the file that is open when you have a crash, it’s kept probably in a cache folder on the hardware internal memory or sd card.

    the problem is when you boot up it asks if you want to discard the crashed file or restore it.

    That file must be saved somewhere in a folder, that I can maybe reach and delete it, because maschine plus is in a loop if I chose discard, or restore, I get the crashed file back when I choose restore, even if I save it and open a new file and save that one, on the next boot I t’s again the same “do you want to restore (file name with time stamp of crash) with “discard” or “restore”, again and gain and again, if I disable auto backup it stops doing it. So that must be a bug, but maybe there’s a temp workaround by deleting “that” file so we aren’t in the loop and still enable backup feature.


    is there a way to set a template?

    Do you mean automatically loading a template project on boot? Nope, only possible on MAS desktop. It might not be a good idea to auto-load projects on a device not so stable, if the project ever has an issue it might stop you from booting. I'd just make a template project with a name that starts with "AA" or "!" so it shows at the top of the list then use a computer to set it as read-only so I never accidentally save over it, not sure how this would affect auto-save tho.

    “It might not be a good idea to auto load projects on a device not so stable” It has happened lots of times on the desktop, you got an error, and could just continue” And about “on a device not so stable”, sorry I can’t believe you wrote that as an admin about one of ni’s main products. It has it’s own Linux os, is the only thing of software that’s running, and as a standalone device should be much more stable than a computer with hundreds of processes ,services and programs. It’s the programming of maschine that’s all. A simple setting in preferences should be possible, to quote your own words in the last paragraph “your M+ is much more like a normal computer than an old-school low res screen standalone.” I know for sure some of those “old school samplers allowed you to set a startup template. And maybe more important, the main competition has had that option since forever...saying such a simple function is impossible is just not believable.

    first thing i need to do is change full velocity from 100 to 127, any way to change that?

    Go to Pad Mode and navigate to the 2nd Page.

    Yes, I know I’ve done it a million times lol, and I know lots of people do that, it would be easy to add this setting in prefs, maybe in the tab for velocity (maybe the one with normal,hard,soft velocity settings)set standard full velocity value:127 or other, could be a nice option in the software too, but there you have the luxury of setting a...template where you can set it to default 127. Full velocity is full velocity after all, not 100.

    Hope this all gets fixed soon, because with standalone hardware you have much less troubles than with a pc, or so they say...

    People just repeat that because others said it, it holds a lot of truth for older devices but even those had bugs too.

    I’m not talking about older devices,nor repeating anyone, but the flagship of the maschine series. There have been times in standalone that there where almost no bugs and it was a real joy to work with. About the time after the drum synth and bassline was introduced. It was fast, never crashed on me, had almost all the features I wanted, it was better than any hardware sampler I ever used on every aspect and my mpc one was gathering dust because it was inferior compared to m+ in standalone, in terms of workflow, sound and the instruments /fx. It was great

    “An M+ is miles apart from standalones from back in the day that had 2mb of firmware, fixing a bug on 600mb of data is not as easy, not an excuse but just saying... your M+ is much more like a normal computer than an old-school low res screen standalone.”

    Yes I completely agree, but as you say, it’s not an excuse. It’s about walking the fine line of stability and adding features without adding bugs. Because if you fix one bug, you can get 3 back. For a lot of people this device is a lot of money, so they expect it to work, and work better with each update not worse. I didn’t enjoy my 5 hours troubleshooting instead of making music yesterday. I even did a reset, take out the thumb drive the correct way, ejecting the sd card thinking it would help, the time lost rescanning it, trying to find the culprit but nope. I don’t expect any hardware nor software to be completely bug free, that’s impossible, certainly when you update it. But it should be workable.Better quality control on the release with maybe more beta testers internal or in a group, maybe this update wouldn’t be the train wreck it is now, I can’t imagine this all hasn’t been noticed it’s not like there are dozen of hardware versions, we all have the same device. I just read about someone that feels we are the beta testers instead.

    Having to wait more than a minute for it to boot up and 2 to shut down, the bug with the backup function I described, The imo higher cpu usage, also hanging and much longer time when rescanning thumb drives , (wich makes me think the slow file reading could be the reason for the long boot time, and writing is slower so on shutdown it should and does take longer) jerky browser behaviour with larger thumb drives scrolling in the browser (wich happened a few times in the maschine soft since 2.0 and is most always a gpu problem), the update that is in a kind of loop, if you press shift and system update in prefs,it will ask to update again and countdown from 60, and there’s more weird behaviour when you read around.

    Sorry if my answers could appear negative, but as a long time (1.0) user this has never happened. Feeling sad and frustrated. We can wait for an update in a few weeks/ months, but the chance to revert to the previous version would be great, hear me out.

    I know there was a link for the normal software version posted, but if I could I would instantly return to the previous m+ version for standalone. Of course the system is different than native acces, but maybe a bootable usb drive or an adaption to the update server where we could choose a previous version would be great. Because it could happen one day, one wrong file, programming error that slipped through, a faulty update via WiFi could make all our maschine+ devices unusable.Save previous install file to return to.Food for thought.

    Hope you understand my point of view.

  • djadidai
    djadidai Member Posts: 377 Pro

    Save a template project, work on your current project, save it, then load the template when ure finished and THEN turn off the M+. That should load the template project when you fire it up the next time, won’t it?

  • JayTee303
    JayTee303 Member Posts: 28 Member


    1st of all, thx for your input and work around. It could work but there are some possible problems with it, if you don’t pay attention.

    “Save a template project, work on your current project, save it”

    Here’s the thing, if you save it you have to remember to choose “save as” and choose a different name. If you choose the quick save, your template will be overwritten.

    “then load the template when ure finished and THEN turn off the M+.” If you remember to save it under another another name, and have “load last project” enabled in prefs. That could work.

    the way I do it now is make template. Make a template_backup, template_backup 2. So when I accidentally write it over with save, I have 2 backups. Then I open the changed template, resave under another name, open the backup, resave as template. Gonna try your way for a while, it’s a good workaround.

    Anyway I’m still rooting for an option to have it in prefs. I find that we should get the same user experience, as much as possible, like the software version.

  • djadidai
    djadidai Member Posts: 377 Pro

    I understand, but to have a template project, just add a group or sound or whatever to it and save it under another name INSTANTLY then you can just quick save under new project name. After u finished just load your template, fiddle with the swing or whatever, quicksave and turn off M+, and it’ll reload last project, which should be your recently saved template project. Easy peasy.

  • badaz
    badaz Member Posts: 36 Member
    edited December 2022

    It's been almost a month since the beginning of this thread and still no hotfix... I must say that I am disappointed. I am a developer myself so I understand things like prioritizing bug fixes, but this one here really seems like a small thing requiring a fast release of a hotfix version 1.4.5. So either they changed something that really modified their "paradigm" and it is not an easy fix, or they just judged that we can cope with it until the next feature release (aka 1.5.0 for example). Either way, we need more transparency on upcoming releases

  • D-One
    D-One Moderator Posts: 2,689 mod

    They have officially confirmed a hotfix is coming, so for now, there's no reason to believe we will need to wait until 1.5.0, that would be pretty bad as I am almost sure there are no more versions planned for this year.

  • D-One
    D-One Moderator Posts: 2,689 mod
    edited December 2022

    @JayTee303 said:

    about “on a device not so stable”, sorry I can’t believe you wrote that as an admin about one of ni’s main products.

    Well, would you prefer I lie and say it's flawless? I've said much worse, trust me... 1 year before the M+ was released I revealed it to the world. I expected to be banished for that one... 🤣

    I'm not an Admin, just a mod... read my signature. My opinion is mine, not NI's, I'm not on the payroll and even if I was I wouldn't lie, I would just stay quiet as they do. Obviously, I do have some obligation to not be rude and bash a product given my forum privileges but saying it hasn't been quite stable is not crossing any common sense boundaries IMO, the folks @ NI are cool and not uptight about these things. It's a decent product in many ways.


    @JayTee303 said:

    A simple setting in preferences should be possible

    And maybe more important, the main competition has had that option since forever...saying such a simple function is impossible is just not believable.

    There's some miscommunication here... You asked if it's possible so assumed you were asking if it's currently possible, it's not so I said "no" as in it's not an available feature currently... I didn't mean it's impossible to implement it; of course it's possible.


    @JayTee303 said:

    I know for sure some of those “old school samplers allowed you to set a startup template.

    Yeah, lots of old samplers do tons of things the M+ doesn't.


    @JayTee303 said:

    I’m not talking about older devices,nor repeating anyone

    I didn't mean you, sorry if that sounded rude.


    @JayTee303 said:

    Yes, I know I’ve done it a million times lol, and I know lots of people do that, it would be easy to add this setting in prefs

    Miscommunication again... Sorry, I thought you were asking how to do it. I agree, it would be very cool to be able to set a default fixed velocity value in the preferences, both for M+ and desktop.


    @JayTee303 asked:

    where are these files located?

    Deleting them should get rid of it.

    The auto-save project is stored internally, 99.9% sure because I couldn't find any autosave.mxprj in the SD and more importantly even without the SD card inserted the M+ is still able to load it.

    Autosave works by saving a temp project every minute or so, since shutdown takes more than that a new one will always pops up at every shutdown, deleting is not an option.


     It was fast, never crashed on me

    See... This is what I am saying, people have different experiences based on how they use things. I had the M+ crash more in 2 years than all my computers combined in the last decade.


    Sorry if my answers could appear negative, but as a long time (1.0) user this has never happened. Feeling sad and frustrated. We can wait for an update in a few weeks/ months, but the chance to revert to the previous version would be great, hear me out.

    I know there was a link for the normal software version posted, but if I could I would instantly return to the previous m+ version for standalone. Of course the system is different than native acces, but maybe a bootable usb drive or an adaption to the update server where we could choose a previous version would be great. Because it could happen one day, one wrong file, programming error that slipped through, a faulty update via WiFi could make all our maschine+ devices unusable.Save previous install file to return to.Food for thought.

    Hope you understand my point of view.

    Don't worry, you don't sound negative to me, I have a much harsher POV than you actually.

    No need for bootable flash drives, the OS/SW can be upgraded/downgraded by just placing the file on the SD, I think they are avoiding that because hotfixes were usually fast and maybe they don't want the full OS files out there publicly. But ask support, open a ticket, and maybe they can send you the SW. A public link on the forum is prob not gonna happen.

  • tetsuneko
    tetsuneko Member Posts: 555 Guru
    edited December 2022

    I too noticed the slow shutdowns after updating to 1.4.4.. should have stayed on the earlier version I think. My bad.

    Man, I didn't even need the 1.4.4. because I haven't updated my Maschine Desktop to 2.16 🤡

  • Pollip
    Pollip Member Posts: 11 Member

    "My bad" - don't think so....

Back To Top