Installing Rise + Hit from Komplete 13U using NA2 - Kontakt Dependency?

Vocalpoint
Vocalpoint Member Posts: 700 Pro

Now that I have NA2 up and running successfuly - I decided to take a stab and see how it handles items from my K13U package that I have not yet installed.

When I click Install on Rise and Hit - I get this odd message:

While this appears to make some sense (on the surface) - Kontakt 6 IS fully installed and available. So....

  1. Why does NA2 think I don't have Kontakt installed (when it is clearly listed as such in NA2)
  2. A quick look into the background of Rise and Hit indicates it needed Kontakt 5.x back in the day - so I am wondering if that is what is being suggested.

After this came up - I started poking around with a few of the (older) Scarbee guitar libs and the same message pops up.

Does anyone know what will actually happen if I hit Install? What actual "required" Kontakt dependency will get installed?

To be clear - I have zero desire to allow any shred of Kontakt 5 onto this machine.

Appreciate any insight that anyone can share.

Cheers

VP

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,935 mod
    edited October 2022 Answer ✓

    @Vocalpoint Native Access 2 is looking to see if Kontakt 7 Player is installed, you can install it if you want, you can install your libraries wheteher you want Kontakt 7 Player or not, if you only want to use Kontakt 6 for now, it's not an issue.

Answers

  • Paule
    Paule Member Posts: 1,328 Expert

    Do you point on Learn more? What happens behind the link?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,935 mod
    edited October 2022 Answer ✓

    @Vocalpoint Native Access 2 is looking to see if Kontakt 7 Player is installed, you can install it if you want, you can install your libraries wheteher you want Kontakt 7 Player or not, if you only want to use Kontakt 6 for now, it's not an issue.

  • Vocalpoint
    Vocalpoint Member Posts: 700 Pro

    That "Learn More" offers almost zero knowledge on the issue or the message. Has exactly nothing to do with this message.

    VP

  • Vocalpoint
    Vocalpoint Member Posts: 700 Pro

    Jeremy

    Thanks for the update but that does not really answer the question. To me - this Install button looks like it will add more than just the Rise and Hit library (like adding Kontakt 7) which I already mentioned that I do not want.

    That said - what is even more odd - is now that I have installed NA2 AND ensured that I have installed exactly nothing to do with Kontakt 7 - I was stunned to see this appear yesterday while using my Komplete Kontrol S61...

    Why is Kontakt 7 being referenced on my S61 when I am not a Komplete 14 user and have made no attempt to install anything related to K7?

    Is this a glitch or bug or what?

    VP

  • Vocalpoint
    Vocalpoint Member Posts: 700 Pro
    edited October 2022

    Jeremy - So I took your suggestion and installed Rise and Hit and sure enough - NA2 automatically kicked in and started the Kontakt 7 player downloading.

    Will give Kontakt 7 Player a try now - but NA2 still should have known that K6 is already installed.

    VP

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,935 mod

    What products had you installed before you noticed that Kontakt 7 appeared in your Komplete Kontrol browser?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,935 mod

    Oh, interesting, so when you clicked on install for Rise & Hit, it put Kontakt 7 in the queue of products to install in Native Access, then was installed without any action from you?

  • Vocalpoint
    Vocalpoint Member Posts: 700 Pro

    Correct. Firstly - Rise and Hit dates back to the K5 days so it should be fine with ANY version of Kontakt - especially 6 - which is my daily driver. Now I have Kontakt 7 "player" on the DAW in addition to K6.

    To be fair - Rise and Hit appears fine in both - And - while K7 Player is not the full K7 - I see it has the new browser and the previews which are of value to me. However - I suppose it (Nor NA2) will allow me to install the new Standard Library v2 without becoming a Komplete 14 customer - and the price is not where I want it to go there yet.

    So - in terms of ongoing NA2 issues - this is another one. NA2 seems to have no idea that a full version of Kontakt is already installed and installs K7 Player anyway. And I assume - if I decide to wipe K7 player off the DAW - NA2 will just put it back there the next time I choose to install a Kontant based product that is not yet installed.

    This needs to be addressed because this is no way a Kontakt instrument for 4-5 years ago "needs" K7 Player to function.

    And to this question "What products had you installed before you noticed that Kontakt 7 appeared in your Komplete Kontrol browser?"

    The only product I installed (as a test) AFTER installing NA2 and before seeing this K7 tag on my S61 was the "Cavern Floor" expansion. It installed fine and the next day I noticed the K7 tile appearing on my keyboard.

    Cheers

    VP

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,935 mod

    @Vocalpoint Native Access will always propose to install Kontakt 7 Player as it's the newest version and comes with Komplete Start, the free bundle you get when you have a NI account. You can still press "skip for now" but it will be proposed again and again. At the moment you can still use Kontakt 6 without an issue. As time will pass more and more libraries will require 7 as a minimum. With Kontakt 7 Player you can still use all your NI libraries, they only require the free version. With the Player version you also get a Kontakt Factory Selection (smaller version of the real thing).

  • Vocalpoint
    Vocalpoint Member Posts: 700 Pro


    Thanks for the update. One thing that you need to clarify is the Kontakt Factory Selection For me with Komplete 13U - this is most definitely not a "smaller version" of the Kontakt 7 library (which would be cool). It is a selection of 50 sounds from Kontakt 5 (according to the little tile in NA2) which makes it even less attractive since I already have my full K6 library already installed.

    And yes - I do understand that K7 is new and shiny and will become the standard at some point - it is not the standard right now as K6 is still probably in use for 99% of users worldwide. I still believe that NA2 should know what version of Kontant is currently installed and navigate that correctly rather than polluting a users DAW with K7 Player - which is clearly not necessary for something older such as Rise and Hit.

    VP

Back To Top