Traktor 3.11.1 update via NativeAccess fails

c0nsul Member Posts: 296 Pro

Like the title says. Updating to 3.11.1 fails and queues the update.

NA is up to date. Tried logging out and in again..

Any ideas?

Best Answers

  • c0nsul
    c0nsul Member Posts: 296 Pro
    edited February 3 Answer ✓

    Well, if nobody installs the update, nobody will notice any bugs... 😉

    Thanks for your warnings, but I´m aware of the risks. I´m trying/testing betas for a long time.

    Seems like I had not granted full disc access. Private Relay could have been the culprit. Now it´s working. Problem solved.

    EDIT: Granted Full Disc Access for NativeAccess and NTK-daemon and re-started the Mac (and updated before PrivateRelay was connected). This resolved the issue for me.

    EDIT 2: First, I assumed Disc Access was the problem, after reading the comments I think PrivateRelay seems more plausible. For this reason I edited this post.

  • ghostly
    ghostly Member Posts: 3 Member
    edited February 1 Answer ✓

    My problem was private relay was on if you've exhausted everything else try this I can't post links yet so ill paste in what the NI article says

    Temporarily deactivate iCloud Private Relay for the installation.

    1. Close Native Access.
    2. Open the macOS System Settings > iCloud > Private Relay.
    3. (You can also use the System Settings search field to find the Private Relay setting.)
    4. Turn off Private Relay.
    5. Restart your computer.
    6. Start Native Access and install your products.
    7. After installation, open the System Settings again and reactivate Private Relay.

    I've known it was on but didn't expect it to cause any problems like this

  • diptronic
    diptronic Member Posts: 3 Member
    edited February 3 Answer ✓

    I had the same Private Relay issue. (MBP M3Pro). It happened with Traktor 3.10 and it just happened again with 3.11. :(

    I'm not sure what re-triggered the Private Relay setting after I fixed it last time. Will need to research.


Back To Top