Unable to use multiple midi input devices at once

myalteredsoul
myalteredsoul Member Posts: 199 Advisor
edited January 2023 in Maschine

When connecting multiple midi input devices, Maschine sends the data from each to all CC's.


Video describing and showing the issue

Midi Config


Tagged:

Comments

  • myalteredsoul
    myalteredsoul Member Posts: 199 Advisor

    It will filter notes coming in, but does not filter midi CC by channel. Is there a way to fix this?

  • 6xes
    6xes Member Posts: 594 Pro
    edited January 2023

    i would guess using the stand alone mode doesnt allow for much filtering...

    consider using maschine inside another Daw that utilises a better filtering method between devices

    Reaper being free to use... has realearn which has alot functionality when it comes to filtering midi in & out of devices.

    heres a overview of realearn


  • 6xes
    6xes Member Posts: 594 Pro

    im also wondering in your example... i noticed you are trying to use different devices on the same group.

    have you tried assigning the devices on a different group??

  • myalteredsoul
    myalteredsoul Member Posts: 199 Advisor

    It still occurs when devices are in different groups

    This issue is still there when running Maschine inside a DAW. It's actually made worse as all midi assignments matching that CC value in the daw will control the one macro.

    I am going to try installing an older version of Maschine to see if this issue is update related.


    It seems pretty daft that Maschine's midi filtering applies to note data only and not to CC data.

  • 6xes
    6xes Member Posts: 594 Pro

    im guessing here... but if you are using hardware, most of the time unless you are able to configure the hardware to send on separate channels... they will inevitably send out on the channel of the hardware which is the default.

    you could run a test on a midi monitor to confirm whether its sending the same CC on the same channels or not

  • myalteredsoul
    myalteredsoul Member Posts: 199 Advisor

    They are all configured for specific channels. Already confirmed via midiox that they are sending cc on their assigned channels (in this case 15 from the nts1 and 1,2 from the mono station.

  • myalteredsoul
    myalteredsoul Member Posts: 199 Advisor

    9 characters

  • myalteredsoul
    myalteredsoul Member Posts: 199 Advisor

    I tried rolling back to maschine 2.1, but the issue is still there. Also found another thread with someone else complaining about the issue.


    https://community.native-instruments.com/discussion/4889/maschine-ignores-midi-channels-from-the-external-hardware-controllers

  • 6xes
    6xes Member Posts: 594 Pro

    heres a possible workaround if you are that way inclined...

    load 2 instances of maschine as a plugin on separate tracks assigning a different midi device to the track

    that would be the next logical step to try.. *shrugs

  • Seqsual
    Seqsual Member Posts: 41 Helper

    It depends on target instrument whether parameter will respond to messages arriving only on assigned MIDI channel or not.

Back To Top