M1 traktor obs blackhole connectivity

dj unsung
dj unsung Member Posts: 10 Sine

Hi all,

Like many other people I would like to go live streaming. For the last few days I am trying to sort this out without success. I know that this issue has been mentioned quite a few times before and I have read many posts but there are details on my settings that I haven't found.

System:

M1 MacBook Air (Monterey)

Traktor Pro 3 (3.5.2 299)

Audio 6

Pioneer DJM 800

2 Technics 1210

1) Through my research I came across OBS and blackhole. First thing after installing everything was to open midi set up and create an agreegate device.

a) I have seen videos were they are creating an agreegate device as well as a multi output device. Should I create only an agreegate device or both?

b) Does the order of devices on agreegate device matters? For example I have Traktor 6 and Blackhole 2ch, does it matter which goes on top?

c) Do I include only these 2 options (Traktor 6, blackhole) on agreegate device?

d) Drift connection should be ticked or not?

e) One more detail in this section is about the icons next to the devices. There are 2 icons in general, one for input one for output. Is this arranged by the choice I make on sound options? Does it matter on which device they belong on midi setup?

  • One detail is that I don't have built input as an option on midi set up.
  • All the settings including traktor are on 48Hz


2) Next step is sound options.

On the scenario that I create only an agreegate device and not multi output I set the agreegate as output.

3) Traktor settings

a) Audio set up. Set it to agreegate device.

b) Output routing. Set it to internal. On output monitor I don't have the option of headphone L and R. These are the options I have for output monitor, output master and output record

After my research my head was ready to explode so I started playing with different combinations of the above things. At some point I noticed that pressing the headphone button on traktor (underneath key knob) would give me sound on my external speakers but both channels would play from 1 channel. To be honest I am fed up. I spent money recently getting the M1 because my old Mac could not handle streaming. I thought that it would be a straight forward process. My technical knowledge is very basic. Please if anyone has any suggestions on how to make this whole damn thing to work it would be much appreciated.

Thank you very much in advance!

Comments

  • Wyley
    Wyley CanadaMember Posts: 236 Saw
    edited February 8

    I don't know if Monterey is working well with everything you're using but I'll see if I can help out. If you just want to use the master out of your djm 800 as the only source of audio into obs then you can try this. For this you have to Set Traktor output to external mix mode

    Make sure that Traktor and Obs is enabled in Microphone settings in the security/privacy settings on your OS.

    In Traktor use in/out 3/4 and 5/6 for dvs instead of in/out 1/2 with your audio6 because obs likes ch1/2 better than the rest for input.

    Master out from Djm into 1/2 on your A6 (make sure Traktor is not using in/out 1/2 at all)

    Open OBS and select audio6 ch 1/2 and you're done.

    Use the mic on the djm 800 and monitor the mix on the djm 800.

    This is the setup most streamers use. Make sure you have the proper OBS updates and plugins. From what I remember you don't have to aggregate audio devices for obs as it will pick up the individual ones.


    Hope this helps

  • dj unsung
    dj unsung Member Posts: 10 Sine
    edited February 8

    Hi Wyley,


    Thanks for your reply. I will try to answer step by step. Obs and Traktor are enabled in Microphone settings.

    When you say to use on Traktor 3/4 and 5/6 do you mean on output routing for output deck A and deck B? I set it up on external.

    Next thing is when you say to open Obs and set it to audio 6 channel 1,2.

    Do you mean going to settings, audio? On audio settings of Obs, on global audio devices, I have everything disable apart from mic/auxilary/audio which is set to Traktor Audio 6 but I don't see any option for channels 1,2.

    With these settings I have signal on Obs and sound on my speakers which is what I am looking for but when I cut the volume of the channel playing, the volume of obs is not affected.

    Do I have to create audio output capture on Obs?


    Thank you

  • Wyley
    Wyley CanadaMember Posts: 236 Saw
    edited February 8

    Yes I mean use 3/4 & 5/6 for deck A & B dvs. (Traktor input & output) Do not use in/out 1/2 for traktor at all

    Use the djm 800 master rca or rec out rca into the input 1/2 on your audio 6

    Then inside obs use audio6 1/2. If it doesn't show up in obs there is a + sign (sources) to add it then mute anything else obs might see other than the audio6 or remove anything you won't ever use on obs. If you can't select 1/2 with your A6 don't worry because it will automatically default to 1/2 hence the reason why I told you to save in/out 1/2 for Obs use instead of using it for Traktor.


  • Wyley
    Wyley CanadaMember Posts: 236 Saw
    edited February 8

    @dj unsung I edited the post above to answer you issue. You can't use input 1/2 in traktor input routing and output 1/2 in traktor output routing at all. Check Traktor settings

  • dj unsung
    dj unsung Member Posts: 10 Sine

    Thank you for your reply,

    I think I have all the settings but my only issue is when I turn down the master volume or the channel volume from my mixer the obs sound levels are not affected. The obs bar continues showing signal and stops only when I remove the stylus.


    Thanks

  • dj unsung
    dj unsung Member Posts: 10 Sine

    In addition when I try to stream there is a hiss and no sound at all

  • Wyley
    Wyley CanadaMember Posts: 236 Saw
    edited February 8

    Take the blackhole device and plug it to your computer then plug the mixer rca into it and add it to obs. Then remove or mute the audio6.

    Do this for now because I don't think you have the right obs plug in yet to do it with a device with multiple ins/outs. I'll look into it later

  • Wyley
    Wyley CanadaMember Posts: 236 Saw
    edited February 8

    Thy this

    Go to the audio panel in Mac Os and create a new aggregate device. Just use the Audio6 to create it and disable in/out 3/4 & 5/6 (configure speakers) then use it in Obs and see if that works. If not you'll have to use the blackhole device until you can find the proper plug in for OBS

    Hope this helps and good luck.

  • Wyley
    Wyley CanadaMember Posts: 236 Saw

    @dj unsung

    Ok, there is no plugin for the Mac version so you'll need the Blackhole device.

    I went through the history of my settings and remembered the my Denon x1850 has 2 built in sound cards which I used one for my iPad and the other usb for my laptop using the broadcast mode setting in which the mixer switches main output for the second card to ch 1/2 for obs. Only windows has the asio plugin to enable the single card use. I only use the Atem Mini Pro now for streaming.

    So stick with the Blackhole to OBS solution.

    There is a thridparty tool for Mac it costs $99 usd. It's called Loopback --> buy.php I might get this as I have other uses for it.

    Check back and let us know how it goes.

  • dj unsung
    dj unsung Member Posts: 10 Sine

    Thank you for your info!

  • dj unsung
    dj unsung Member Posts: 10 Sine

    Hi Wyley,

    Still haven't found a solution to my problem and sort of given up at the moment.

    I came across loopback and considering it but I am not sure if this software will solve my problem. I will let you know when I find a solution.

    Thank you

  • Stevan
    Stevan MIDIMember Posts: 237 Saw

    Hey, I was also testing all possibilities to stream from M1 mac. What gave me the best latency was Screenflow's audio driver that is used to capture the computer audio. Blackhole also works but it had more than 18ms delay.

  • dj unsung
    dj unsung Member Posts: 10 Sine

    Hi Stevan, thank you for your reply. Can I ask you how do you set up traktor regarding output routing when you use blackhole?

    Internal or external? When I was trying to find a solution with blackhole I was setting traktor to internal and the problem I had was that I didn't have any sound at all through my monitor speakers. You are talking only about latency so I must have done something wrong.

    Thank you

  • dj unsung
    dj unsung Member Posts: 10 Sine

    Some people suggested not to use blackhole and set traktor output routing to external. With this scenario everything is fine and the obs sound bars show signal but when I try to live stream the only sound I get is the timecode signal from the stylus. Also the obs sound bars are not controllable from my mixer. To be honest I think this is the right way but there must be a compatibility issue. I have contacted so many people found on youtube regarding live streaming, some of them with turntables but none of them could give me a solution. I have registered to a couple of dj forums. Even here I am disappointed with the number of replies, are there any people who live stream with timecode vinyl? It is a combination of different softwares and that makes it more difficult I get it but still. Anyway peace!

    Thanks

Back To Top