Huge problem with Maschine software - instruments changing pitch randomly after opening a project

Options
jakubpatok
jakubpatok Member Posts: 55 Advisor

Hello everyone,

I have a huge problem with Maschine software. I create a new project, work on it, add various instruments, everything is okay. Next day, I open the same project that I created the previous day and various instruments that I recorded into this project completely change their pitch out of nowhere. The melodies in a piano roll stay the same as I recorded them yesterday (their sound also doesn't change EXCEPT FOR the pitch), but the instrument doesn't play a proper note (for instance, in the piano roll I have a note A but what I hear is not A note but for example G). It happens randomly - sometimes for one instrument, sometimes for two or three. Nothing happens in the rest of the project. However, the plugins that changed their pitch completely ruin the whole track as they are completely out of tune. First I thought that the problem only concerns Kontakt plugins but it has happened to Massive today so it's definitely a problem with the Maschine software. It happened once or twice that I reloaded the project and it came back to normal but very rarely, unfortunately. One (let's say) solution is to reload a plugin that changed the pitch but if I didn't save the patch/preset that I tweaked then I have to recreate the sound and it takes so long that I lose all the interest in working on the project.

Please help because the issue is very annoying. Fortunately, it doesn't happen to all my projects but still quite often. I need to recreate the whole thing if the situation occurs and it makes me so annoyed. I'll be very grateful for any tips how I can fix the problem.

Tagged:

Best Answer

Answers

  • Schmapps1
    Schmapps1 Member Posts: 135 Pro
    Options

    My first thought is that you might have a sample rate conflict going on somewhere?

  • jakubpatok
    jakubpatok Member Posts: 55 Advisor
    Options

    Can you elaborate a bit, please? How can I check this? Is the problem solvable somehow?

  • Schmapps1
    Schmapps1 Member Posts: 135 Pro
    Answer ✓
    Options

    What I mean is, perhaps your audio interface is set to a different sample rate then you are set to in your maschine preferences. Or, you are using a VST that has an internal sample rate setting that differs from that of your maschine (or your audio interface setting). Totally solvable, you just gotta check!

  • jakubpatok
    jakubpatok Member Posts: 55 Advisor
    Options

    Thank you VERY MUCH! I had my audio interface set to 48000, I changed the sample rate to 44100 and the projects do not sound out of tune anymore. It seems that the plugins were set to 44100 and when I had the audio interface at 48000 there was a problem. Do you think I should change the sample rate of plugins or can I keep the audio interface sample rate at 44100? I have Komplete Audio 1 interface and it was set to 48000 by default and I'm worried that it should stay at this rate. But it finally works so I'm happy and really appreciate your help. 😁

  • Schmapps1
    Schmapps1 Member Posts: 135 Pro
    Options

    You are welcome! I’m glad it worked out - I know how frustrating that can be!

    Personally, I like to keep everything set at 44.1….but opinions can vary on that, that’s a whole other discussion haha. But I feel like 44.1 is still the usual standard for most applications

  • jakubpatok
    jakubpatok Member Posts: 55 Advisor
    Options

    The bug occured in so many of my projects that I was extremely frustrated with it.

    When it comes to the sample rate - for many years I worked without an audio interface (I know, it's a crime!) and I had everything set to 44100. Two years ago I bought Komplete Audio 1 and it was set by default at 48000 and I thought that it was supposed to be like that. I set all DAWs and software at 48000 then because of the audio interface's default settings. However, I was not aware that some plugins have their own sample rate and probably Kontakt or Massive are set by default at 44100. Still, I am not sure why it didn't happen to all my projects but only a few of them. It remains a mystery! I think I'll keep the sample rate at 44100 because all the flawed projects worked nicely now. Thank you very much once again!

  • manolo.floyd
    manolo.floyd Member Posts: 13 Member
    Options

    I had similar problem without changing anything on my setup. Like I was playing the project, then 5 minutes later I press who knows what combination of keys and suddenly it's out of pitch. The explanation above makes sense but what if I didn't open or change the audio preferences?

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,628 admin
    Options

    @manolo.floyd Your issue is during the same session so might have a different cause from the OP. Do you have any MIDI controller connected? It could be that your midi controller is sending unwanted signals which affect the pitch. Maybe use this to check just in case: http://www.midiox.com/

  • w1ntermute0
    w1ntermute0 Member Posts: 1 Newcomer
    Options

    Are you using maschine as a plug-in to a DAW? I was having this problem when using maschine in Cakewalk by Bandlab. Turns out there is a setting in Preferences >Project >MIDI called "Zero Controllers When Play Stops". Un-checking this option (seemed to be on by default) fixed it for me. Mine would go out of pitch after playing and then stopping, then re-starting a song at certain points. Very annoying until I found this.


Back To Top