Maschine 2 not working (MacOS M1 Max, Monterey 12.5)

Cajetano
Cajetano Member Posts: 6 Sine
edited August 2 in Maschine

Because my old MacBook Air was a little bit "old" (11 years, but fluent less working) I had, presumably, some performance problems with Maschine and more than 8 tracks and decided to buy a new one.


Now I have purchased a MacBook Pro M1 Max with enough memory and Komplete I installed Maschine 2 but every time I start it, Maschine 2 (2.15.2)will crash or freeze or something.

What is going on?

Best Answer

  • Blojam
    Blojam Member Posts: 2 Noise
    Answer ✓

    Just in case anyone has read my comment above, my issue has now been resolved. I can't explain how it happened but after a day and a few reboots, it's working.

Answers

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 1,444 Pulse

    Maschine is still not certified compatible with M1 processors as outlined in the following document.

    Apple Silicon (M1 / M2) Compatibility News – Native Instruments (native-instruments.com)

    You can try running in Rosetta mode.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod

    @Cajetano How does it freeze/crash exactly? Is it happening when you are trying to preview instruments or kits? Then you would be affected by this issue:

    Maschine software hangs while previewing kits - Bug (KBDSW-6977)


  • Blojam
    Blojam Member Posts: 2 Noise
    edited August 3

    I am having a similar issue. I'm using a MacBook Pro M1 Max (64Gb Ram) and trying to use Maschine 2 as a plugin inside of Logic, to drag and drop the audio files from a project for arranging and mixing. Each time I activate the channel with Maschine on it, I get the spinning beach ball and Maschine fails to load. The beach ball never stops spinning and I have to quit Logic. When I open the same project in Maschine 2 software on its own (outside of Logic), it opens normally.

  • Blojam
    Blojam Member Posts: 2 Noise
    Answer ✓

    Just in case anyone has read my comment above, my issue has now been resolved. I can't explain how it happened but after a day and a few reboots, it's working.

  • Cajetano
    Cajetano Member Posts: 6 Sine

    Yesterday I managed to run Maschine 2 :


    I started a Terminal with Rosetta Configuration

    There I started Maschine 2 from the Terminal, opened a Group, put the first instrument into it and then I was able to run Maschine 2 without freezing.


    Today I tried the same procedure, but everytime Maschine stalled and freezes and I had to kill the Application.


    This is very disappointing

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod

    @Cajetano Maschine 2 should automatically run in Rosetta mode since it doesn't support M1 natively. What you are describing is probably this issue: Maschine software hangs while previewing kits - Bug (KBDSW-6977)

    The fix is to downgrade Maschine to the previous version, you will find a link to the installer in the thread.

  • Cajetano
    Cajetano Member Posts: 6 Sine

    Sorry,


    didnt had time to answer because of working.

    Now I have holiday and time to use Native Instruments.


    I have upgraded to Ventura 13.0 and while Machine 2 is working a little longer, it freezes after 5 Minutes :-((

  • Cajetano
    Cajetano Member Posts: 6 Sine

    I have now ran Maschine 2 from a Rosetta Terminal for about 15 Minutes and it is still working...

  • Cajetano
    Cajetano Member Posts: 6 Sine

    Now it stopped :-((

  • Cajetano
    Cajetano Member Posts: 6 Sine

    Is there a plan to supply Native Instruments on M1?


    I have the impression, there is nothing in the pipeline and would know if there is a timetable


    I have the impression that, if I would use Apple M1, I should switch to another solution

  • Nico_NI
    Nico_NI BerlinAdministrator Posts: 967 admin
    edited October 25

    Maschine is set to be compatible with M1 soon. You can see our timeline below:

    Regarding Ventura, please read our macOS 13 Compatibility Statement.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 2,707 mod

    @Cajetano Have you tried the previous version of Maschine (2.14.7), as shown in the thread I posted before? This has fixed the issue for most users.

Back To Top