Beatgrid dont works correct

matthias frühmorgen
matthias frühmorgen Member Posts: 8 Member

hi all. since the last update to traktor 3.5.3.303 my beatgriding makes funny things.

If i select multiple tracks and choose analyze track, the beatgrid is set not evenly. if i select a single track and choose analyze track, the beatgrid is set evenly.

any solution?


Tagged:
«1

Answers

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,546 admin

    Hey @matthias frühmorgen we might need you to send us some tracks so we can try to reproduce on our end. Can you please contact our support team directly? https://bit.ly/n1trakt

  • matthias frühmorgen
    matthias frühmorgen Member Posts: 8 Member

    it happens only with non electronic tracks i saw.

    i noticed, that it happens only on pop tracks. electronic tracks are not affected. but its ok for me.

  • matthias frühmorgen
    matthias frühmorgen Member Posts: 8 Member
    edited June 2022

    ok. i saw now it also happens with electronic tracks... but you dont need my tracks. i have thousands of tracks. and its the same thing with all tracks. its not a problem of my tracks for sure. if you analyze a group of tracks (as example 100 tracks), then it dont sets evenly beatgrid. if i take the same track alone, it sets evenly beatgrid.

  • matthias frühmorgen
    matthias frühmorgen Member Posts: 8 Member
    edited June 2022

    its really annoying and it must be a problem with the version of traktor. i never had this before. i use traktor since about 8 years now. analyze only works proper (means evenly beatgrid) with single tracks selected. not if you take a bunch of tracks (more then 20 or so). i can analyze the same tracks 3 times, it dont works til i select each track single.

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,546 admin

    @matthias frühmorgen We'll need to take a closer look. I've created a support ticket for you. We'll get back to you soon.

  • Alex Dutch
    Alex Dutch Member Posts: 27 Member

    I have the same. I there a solution?

  • solsta
    solsta Member Posts: 93 Helper

    I wonder if this is what I made a support ticket about, my Traktor was glitching with my tempo and beat grids and wouldn't cue on one deck or the other sometimes for an unknown amount of time and then reverts, or until you restart the software, really weird issue

  • NeilCastle75
    NeilCastle75 Member Posts: 1 Newcomer

    Hi, I'm having the same issue as well, if I block analyze the best grid is all over the place. Really analyse it never used to be like this. Must be an issue with the update

  • zephry
    zephry Member Posts: 582 Pro

    The behavior is kind of strange and I think it started when Automatic was added to the range preferences. I have noticed Automatic gets most bpms correct but the grid can be a bit random. And tracks like Dubstep end up 70 instead of 140.

    Here is what I have found.

    The best way to analyze batches of tracks is and even single tracks is in the browser keep the same range of bpms in the batches chosen. Right click and select the Special button to choose your bpm range per batch that you analyze. Of course also select all other options to.

    It seems like an accurate grid is (sometimes) based on the correct range and bpm. This also helps keep from doubling or halving the actual bpm.

    It is a bit more time to spend but as long as you get the bpms correct you can then sort by bpm and analyze the ranges for a more accurate result. So simply use Automatic range on all.. then sort and analyze the groups of ranges with the correct range.

    You could also quickly analyze and select a different range whenever the grid looks wrong. But that can be distracting live.

    If you use Beatport or Beatsource streaming it is best to make playlists and use the offline locker for a good workflow and accurate analysis. The tracks need to be analyzed from the collection or a playlist added to your Traktor playlists. You cant analyze from the browser using the online playlists. And have to rely on the track deck analysis instead.

    There is also an issue that is on Beatport/Beatsource side with the beginning of tracks missing information so the grid is set a bit further in. This is not Traktor it is also an issue on other Dj software using streaming. As long as it is set 4 beats in it is probably fine.

  • zephry
    zephry Member Posts: 582 Pro

    To choose a range it is best to stay near the top number and don't exceed it with the batches analyzed.

    So 68-135 you would not analyze tracks above 135bpm.

    Kind of ignore the lower number in the range. Typically you won't be getting bpms below 88bpm much. Or above 175bpm.

    So the ranges to pay attention to, end in 95, 115, 135, 155, and probably rarely 175.

  • zephry
    zephry Member Posts: 582 Pro

    Also pay attention to other preferences. In the Analyze Options preferences be sure to have Set Beat-grid when detecting BPM checked.

    The second picture at the top of this post shows a track that did not have a beat grid set at all.

    And when analyzing from the browser if Special is selected be sure the other options get done as well.

  • wayfinder
    wayfinder Member Posts: 357 Guru

    isn't dubstep 70 bpm? if it were 140 it would be the tempo of uplifting trance, but dubstep is half that, so 70 sounds about right. i know they CALL it 140, but that's just a name.

  • zephry
    zephry Member Posts: 582 Pro
    edited December 2023

    I have always considered it 140. Mainly because the range tends to be anywhere from 130 bpm up to 150 bpm.

    I mean no disrespect as it can be mixed at half speed. In fact the rhythm is a halftime beat. So it is intentionally made mostly to fit the drums at either tempo. That's what gives the genre so much room in between beats, for the vocals and crazy bass. You can't achieve that with 4 to the floor style quite as easily.

    Here is a quick search I did. It is debated quite a bit. But most agree it should be 140bpm.


  • wayfinder
    wayfinder Member Posts: 357 Guru

    interesting - wrong, but interesting!

Back To Top