Bug: deck suddenly not being able to play

creal
creal Member Posts: 36 Member
edited September 2022 in Traktor Software & Hardware

Hello,

I am using Traktor 3.5.3 with a Kontrol S4 MK3, running on Windows 11 (last update).

Yesterday night, I had a wedding gig. I played a few songs. Everything went well. But suddenly, I tried to play a song on the deck B, and nothing happened. It was as if the play/cue buttons don't do anything (both on the controller and in the software). The song could not be played at all. It was stuck. And the problem remained with every track I put in the deck B. I was forced to use the deck D which prevented me to use the plugged microphone for the rest of the night.

It was a very frustrating experience. And it's not the first time this bug appears.

Have you ever encountered this type of problem? If so, how can I solve it without restarting Traktor, please?

Maybe there is a kind of "lock deck" function I enabled unintentionally?

Thanks for helping,

creal.

Tagged:
«1

Comments

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,467 Expert

    I have not encountered it but here is something you could try if it happens again. Cycle through the deck types, or, if using the S4, activate SHIFT+EXT to enable line-in for the deck, then switch back.

    TT-mode could also be a culprit. If you use it and it starts to make trouble, switch to jog-mode (and vice versa). The most recent version of Controller Editor introduced problems with TT-mode, so you may want to roll back to version 2.6.2.

  • creal
    creal Member Posts: 36 Member

    Thanks for the tips, Sûlherokhh. This is exactly what I tried, but changing deck types and switching to external signal did not change anything. I have not tried to switch to jog/TT mode though. I will think about it the next it will happen.

    I am already running Controller Editor 2.6.2

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,525 admin

    Did you get an error message like Deck Locked or something @creal?

  • creal
    creal Member Posts: 36 Member

    Not at all.

  • Dj pako
    Dj pako Member Posts: 31 Helper

    The exact same thing has happened to me a few random times with traktor 3.4.2 & S4mk3 on windows 10.

  • creal
    creal Member Posts: 36 Member

    Thanks for your feedback, Dj pako. Maybe is it time to do something, @Kaiwan_NI ?

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,525 admin

    I wonder if this might be related to a known issue... Our support team will need to verify. Can you please get in touch with us directly here https://bit.ly/n1trakt?

  • creal
    creal Member Posts: 36 Member

    Okay Kaiwan. I just submitted the issue, sending them the thread link to get a full description.

  • solsta
    solsta Member Posts: 90 Helper

    woah I am having this issue exactly ,


    with my Traktor Pro 3 (latest update) and Ventura on a MacBook Pro M1 Max, I thought I was going crazy!!!


    I suppose I will also submit a ticket.

  • solsta
    solsta Member Posts: 90 Helper

    I'm just now realising, when I update my Traktor, it technically installs another app at times and so my funl disk access is reset, so I'm going to add that and see if this issue happens again, but it happened in a previous version of Traktor which would have had this activated already

  • knetter
    knetter Member Posts: 3 Member
    edited September 2023

    I had the same already a couple of times during rehearsal of my gig night!

    Version: Traktor PRO 3.10.0 71

    H/W: Macbook Pro M1 with Numark Mixtrack Pro 2 controller.

    It is making me very uncertain and makes me think maybe Traktor wasn't the right choice to learn for DJing :(

    For me it happens when I do a lot of rewinding (not in scratch mode), for example to prep a cue point. Then suddenly the track doesn't start anymore and the sync-indicator goes absolutely haywire. Unloading, or loading another track doesn't help, the deck is doomed, dead, passed out. Only restarting traktor brings it back to live, which is unacceptable in a live situation. This issue has been there for a loon time already, come' on devs we have a prio 1 here!

  • solsta
    solsta Member Posts: 90 Helper

    Wow exact problem I had. One deck becomes useless. Just one. And a restart fixes it. I wonder why, how long have you had this problem? I wonder if you disconnect controller and reconnect if it works, though if controller is soundcard then it’s similar to stopping traktor as far as music goes, but maybe it can help us figure out what’s happening. Cos it’s clearly software if me and you got the same issue and I was running traktor hardware

  • c0nsul
    c0nsul Member Posts: 291 Pro

    It sounds like the long known bug around "only loading into stopped deck" feature.

    When this feature is disabling (in preferences) the bug does not occur.

  • creal
    creal Member Posts: 36 Member

    I agree. It's completely unacceptable and we should all change software since this urgent bug is still not solved today. And the idea to disable the "only loading into stopped deck" is too dangerous.

  • solsta
    solsta Member Posts: 90 Helper

    Jeez, only loading onto stopped deck is arguable the most important feature dj software can have. And it’s been an issue for how long? I only came across it this year, thanks for the insight

Back To Top