Why is GR6 crashing every time I load in a component?

gillwibson
gillwibson CaliforniaMember Posts: 2 Noise
edited May 20 in Guitar Rig & FX

First, here are my specs:

Windows 11, Intel i7-8565U Quad-Core, 16GB RAM, GeForce MX150.


For some reason, almost every time I load in a component on Guitar Rig 6 it overloads the CPU and crashes. I can sometimes get it to load in by double-clicking a component instead of dragging it into place which crashes 100% of the time. Loading in amps is near-impossible, and effects like Reverbs crash after about 30 seconds of working. Playing guitar into it just makes it stutter because it's exceeding 100% in the top-right corner before it eventually just crashes 15 seconds later.

Given I have an 8th-gen quad-core i7. I don't think the CPU should be overloading like this, especially when GR6 is the only thing running. Maybe I misunderstand the CPU Percentage thing in the corner, but I don't think my CPU should be struggling with this. I checked the hardware requirements listed to run this program, and my computer well exceeds them.

My only guess would be maybe it's only using one core of my processor? In looking around I found someone saying this issue was caused by the GPU. I know when I first downloaded Minecraft on this computer it was using the Integrated Graphics Card from the CPU instead of the GeForce one and I had to change that. I am not sure how I would go about checking or changing this in GR6. If you know, please tell me.


TLDR: GR6 is overloading really easily and from what I know it shouldn't be doing that given my computer's specs and the minimum specs listed on the website.


[Edited because I accidentally uploaded before I was finished typing it all out]

Best Answer

Answers

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 987 mod

    We had reports of performance issues due to certain graphic cards but the Geforce MX150 is not in the list of these graphic cards. Did you install the latest driver for it? You should also be able to select high performance for the graphic card on a per program basis, as explained in this article.

  • gillwibson
    gillwibson CaliforniaMember Posts: 2 Noise

    I went ahead and switched it to use the GeForce one exclusively. While this made it marginally better it was still getting pretty high on that percentage counter at the top right. I opened up that Task Manager while the program was running and encountered an interesting issue. The GPU usage would go randomly from around 20% straight up to 100% and back in the blink of an eye when it got around 100% on the counter. CPU Usage never really exceeded 15-20%, and Memory Usage never exceed 50% (and that's with several Chrome tabs open in the background). Any thoughts on this?

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 987 mod

    Interesting, maybe @Eddie_NI has a better idea of what's going on here ?

  • Daniel JH @ NI
    Daniel JH @ NI BerlinProduct Team Posts: 3 mod
    Answer ✓

    Hi @gillwibson ,

    Can you please confirm you are using the latest Nvidia drivers for the card?

    If that doesn't help, I would suggest using Guitar Rig at a lower view size scale (change the 100% to 75% in the top left of the title bar). Unfortunately, the Geforce MX150 is not a very powerful card and antialiasing can push it quite a bit. See here for performance comparisons: https://gpu.userbenchmark.com/SpeedTest/332822/NVIDIA-GeForce-MX150

    We are investigating what we can do about improving graphics performance in Guitar Rig 6 but I can't give you any promises or release dates. Just letting you know we are aware and actively looking into it.


    Cheers,

    Daniel

  • T.S.
    T.S. Member Posts: 2 Noise

    AND Ryzen 5 5600x, 32GB memory


    Yeah, I clicked on Components and Reaper totally crashed, disappeared. I've never had that happen before.

    I just started using Guitar rig 6 yesterday, it appears this bug has not been fixed. This scares me and I wonder if I have to quit using it?

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 987 mod

    Hey all, just to make sure, please check the following:

    1. Make sure to update your graphic's card driver.
    2. Run Guitar Rig and your DAW as administrator: How to Run a Program as an Administrator
    3. Follow the steps in this article: GUITAR RIG Crashes at Startup (Windows)
    4. Also check this article: How to Resolve Performance Issues with GUITAR RIG

    In the case Guitar Rig still crashes, please get in touch here.

Back To Top