Internal midi won't trigger any internal synthezisers

Options
eiccolo
eiccolo Member Posts: 2 Newcomer

Hello, I have just bought the Reaktor.

I create an essemble that contains Spiral and Carbon. In the "connect" of Carbon I put internal midi in as Spiral. Spiral is running. No triggering occurs. White midi light blinks though. If I connect external midi source instead, it works properly.

I have tried all combinations of Reaktors sequencers and synthesizers, and midi from internal source never lands to the internal synthesizers.

What is the problem? So annoying.

Best Answer

  • colB
    colB Member Posts: 857 Guru
    Answer ✓
    Options

    I'm guessing that you have both carbon and spiral loaded in as nested ensembles. Then you are trying to send receive midi between those nested ensembles rather than between the actual instruments.

    There are two options:

    #1 keep them as nested ensembles. Double click on Spiral, this should take you down a layer to the actual instrument. select that, go to connect tab in Properties, then in the MIDI OUT section, click internal and choose both 'carbon' entries… one is for the instrument, the other for the nested ensemble…. so one will work… or just try one then if that doesn't work, try the other…

    #2 Alternatively (much better and cleaner IMO), load in the two ensembles, then for each, click down, select the instrument, hit CTRL+X to cut it, then double click to go back up the layer to your new ensemble, and paste the instrument there. Once you have done that with Spiral and Carbon, you can delete the two nested ensembles. You should have two instruments inside a single ensemble. Now the MIDI setup should be easy, all you need to do is go into the MIDI OUT for spiral, and in the internal dropdown, choose carbon as a target and it should just work.

Answers

  • colB
    colB Member Posts: 857 Guru
    Answer ✓
    Options

    I'm guessing that you have both carbon and spiral loaded in as nested ensembles. Then you are trying to send receive midi between those nested ensembles rather than between the actual instruments.

    There are two options:

    #1 keep them as nested ensembles. Double click on Spiral, this should take you down a layer to the actual instrument. select that, go to connect tab in Properties, then in the MIDI OUT section, click internal and choose both 'carbon' entries… one is for the instrument, the other for the nested ensemble…. so one will work… or just try one then if that doesn't work, try the other…

    #2 Alternatively (much better and cleaner IMO), load in the two ensembles, then for each, click down, select the instrument, hit CTRL+X to cut it, then double click to go back up the layer to your new ensemble, and paste the instrument there. Once you have done that with Spiral and Carbon, you can delete the two nested ensembles. You should have two instruments inside a single ensemble. Now the MIDI setup should be easy, all you need to do is go into the MIDI OUT for spiral, and in the internal dropdown, choose carbon as a target and it should just work.

  • eiccolo
    eiccolo Member Posts: 2 Newcomer
    Options

    Thanks, second option worked. Why if I not extract the instrument there are two inputs/outputs for midi?

  • colB
    colB Member Posts: 857 Guru
    Options

    Its possible for ensembles and instruments to send and receive MIDI, so Ensembles and Instruments will show up in the drop down. Most of the factory entries are an instruments wrapped in an ensemble, both with the same name, so you get two entries with that name, one for the ensemble and one for the instrument.

    This seem an odd choice. But it makes sense historically when so many of the newbie 'Why cant I get any sound - Reaktor is rubbish' posts we due to folk not knowing that an instrument needs to be wired to the outputs of an ensemble to work… because reading manuals is just so damn difficult I suppose!

Back To Top