How to force button to send PC message?

A .
A . Member Posts: 4 Sine
edited May 26 in Building With Reaktor

I've made little ensemble for Program Change messages automation control.

I can't force button to send message when it depressed with mouse, but when I use it with assigned OCS control - all works fine.

This is base structure of the ensemble, "List" is used for choosing of desired PC number.

I tried to replace "Add" module with "Value" - no success. What is missed?


Tagged:

Comments

  • colB
    colB Member Posts: 241 Saw

    Not sure, but looking at your structure, it's clear that every time you make a selection from a list, a message will be sent - which is probably not ideal. Better to use a value module, so the list output goes into the value input, and the button goes into the value's trig input. That way you get exactly one output from each button press, and nothing from changing the list selection.

    How are the buttons configured? trigger, gate, toggle?

    What is the 'on' value?...

    If you use the buttons set to trigger, without changing the on value, then the value getting to the program change module is the list value plus 1...

    It's good to get into the habit of testing stuff programmatically. In this case, I would create a numeric display and feed the output of the merge into it, then it's easy to check if the value getting to the Prog Change is the one you expect!

    Trigger mode can be problematic on some DAWs - iirc Live can have issues with this, so I use gate mode with a separator after the button so that only the 'high' valued events pass through.

    Something like this:

    No guarantees that this will fix your problem - that could lie elsewhere ;)

    You might also want to stick a snap value between the merge and the Prog Ch. depending on the init behaviour you want. If you want it so send a prog change to match the last one selected on initialisation, then this is a must, otherwise there's no need...

  • A .
    A . Member Posts: 4 Sine
    edited May 18

    Thank you, colB!

    I use lists only for making presets, so there's no risk to send "fake" message.

    Tried all button modes and values - no success. May be problem is within interaction between plugin and host...

    I have found a bit wired solution - but enough for me.



    I noticed, that "Hold" module send PC after hold time even when button doesn't work. So - I use it (+ "Separator" to avoid double event).

Back To Top