Maschine Crashes on Macbook Pro M1 - Monterey

Jesse J
Jesse J Member Posts: 12 Sine
edited June 17 in Maschine

Hi guys , I am using Maschine Hardware MK3 + Macbook Pro M1 ( Monterey )

Just bought the Macbook 1 week ago and decided to get the Maschine a few days later as it appeared to be the ideal combination to move forward with my workflow , however...

I have had nothing but issues using the standalone software ( 2.15 ), where it will crash 100% of the time from the browser

If I am using the MK3 and browsing through the libraries it somehow freezes the software on the Mac , at first I thought it was random but have replicated the issues over the past 4 hours or so of sitting here frustratingly trying to load things in

Imagine spending all this money on hardware only for it to be unusable out of the box???

I have searched the web and youtube to see if any one is having similar issues and if they have been resolved , I am aware that NI have put a statement on their website saying that there are issues with the new M1 chip , but that by running my "DAW in Rosetta" will help... unfortunately Rosetta is not the answer

Everytime I am in the browser preparing to load instruments ( browsing on screen 1 of the MK3 ) , and then moving to screen 2 to get inside the libraries , the software on the Mac will crash when just previewing the sounds , at this stage I cant even get past this point to load sounds making the hardware and software good for nothing

I saw somewhere that by going into mac preferences and setting "Full Access to Disk" under security , and allowing NI and Maschine to have those priveledges was supposed to help but unfortunately for me I have a brand new product that is useless

If anybody can help me make some progress with this I would be very thankful

«13

Comments

  • djadidai
    djadidai MalmöMember Posts: 177 Saw

    downgrade to 2.14.7, they will fix some issues with 2.15.

  • djadidai
    djadidai MalmöMember Posts: 177 Saw

    this link is from Jeremy from NI taken from another post in the forum.

  • Jesse J
    Jesse J Member Posts: 12 Sine

    Thanks heaps man I will try that

  • djadidai
    djadidai MalmöMember Posts: 177 Saw

    you’ll enjoy it!!

  • nightjar
    nightjar Member Posts: 416 Saw

    Sad that this happens even after all the delayed release drama......

    Hope a skunk works team is getting all the resources they need to come to the rescue later this year...

  • Jesse J
    Jesse J Member Posts: 12 Sine

    Can confirm the older version Maschine 2 214 works just fine , however now I am having issues with Komplete Kontrol not loading anything ... what a nightmare this software bundle turned out to be

  • djadidai
    djadidai MalmöMember Posts: 177 Saw

    can you describe in more detail? Do u run Komplete control in logic as au assuming you use logic? Have you started logic in rosetta mode? Or do you want to open Komplete as a vst within maschine 2? Or do you just run Komplete stand alone? Or as a vst2 and not 3?

  • Jesse J
    Jesse J Member Posts: 12 Sine

    Iv tried all of the above , I found that it does work , it is just Battery that does not load , for some reason , if thats not a part of the bundled software then it shouldnt be in there because I was confused as to why none of the patches would load only to read the scrambled information all over the internet that it is a purchasable upgraded , kind of annoying that its there as an option but will not load

  • NXBYL.PMG
    NXBYL.PMG Member Posts: 5 Sine
    edited May 22

    @MartinBailey I was having the same issue with my MBP M1 Pro, but now I can't even get past the scan without it stalling which in turn will not allow me to try your suggestion. Hopefully NI will get the compatibility challenges with M1 Pro/Max corrected sooner than later. Thanks for the info.

  • Jaheid19
    Jaheid19 Member Posts: 29 Sine

    I will test this today on my IMac. I've had the same issues happening to me.

  • Jaheid19
    Jaheid19 Member Posts: 29 Sine

    I think if you press the ESC button you can skip the scan process.

  • solsta
    solsta Member Posts: 13 Sine

    Woah can confirm I have a maschine Jam and Maschine Studio connected and any time I browse, the whole thing crashes on me :( :( I was preparing to cry in a corner until I saw this post.

    Can confirm, rolling back resolved the issue for now.

    also please lord when will we get retina graphics, my eyes hurt I love you though NI

  • Jaheid19
    Jaheid19 Member Posts: 29 Sine

    Rolling back to 2.14 solved my issue of Machine crashing when loading sounds

  • CarrieM
    CarrieM Member Posts: 4 Sine

    This has also been happening to me, M1 mac, Maschine mk3 (latest software) and Maschine Jam. the rollback version from the link above works for now - THANKYOU!

Back To Top