Audio output Routing with KOMPLETE AUDIO 6

mikee808
mikee808 Member Posts: 3 Sine

What is the proper output routing in order to monitor when using TRAKTOR PRO 3 and KOMPLETE AUDIO 6 mk2? I'm having a difficult time figuring this out. The master out works fine. I'm using a M1 Mac Monterey. No external mixer, powered monitors.

Best Answer

Answers

  • Nico_NI
    Nico_NI BerlinAdministrator Posts: 654 admin

    Hey Mike, what do you mean by monitor?

    In Traktor's Audio preferences, simply select KOMPLETE AUDIO 6 as audio device, and make sure to route the Output monitor to the according stereo output of the KA6 (usually 1/2).

  • mikee808
    mikee808 Member Posts: 3 Sine

    The KA6 is selected in settings. When I say monitor I mean to pre listening to a or b deck in Traktor through the headphones. I do have the main out as 1/2 and monitor as 3/4. I have the headphone icon selected in Traktor.

  • Voyager
    Voyager Member Posts: 2 Noise

    I don't have the KA6, but i did just get the KA2.

    I'm a little surprised that both headphone and line out on this is one channel (1+2 for stereo). There is no seperate out for line and headphones.

    Now you could use the KA for either headhpone or main, and use another output for the other. Unfortunately Traktor doesn't allow this, you need both outs in one device.

    Since you use osx, you're in luck, you can make a work around by using an agregate device in osx.

    You use audio/midi setup app, which is installed on every mac. Create a new agregate device and add 2 outputs into that. Then you can select this created divice in Traktor and route the outputs where you want it.

  • mikee808
    mikee808 Member Posts: 3 Sine

    Is the KA6 not designed to pre listen to other tracks with Traktor? I can not pre listen in my headphones while a different deck is playing through to the main speakers?? Im not having any luck once I created the aggregate device. Seems complicated. I remember years ago setting up the Audio 8 and there were no issues. what's the deal. Thanks

  • Voyager
    Voyager Member Posts: 2 Noise
    edited April 5

    I was under the impression you could listen to headphone and line out separate, but it seems you can only listen with headphones between line out and line in. There is only one set of outputs.

    This is how i set it up previously.

    The built in output i use for headphones, displayport for speakers.

    In traktor you then can select this agregate as audio device.

    To bad traktor doesn't allow you to select in and outs from different devices, but at least there is a workaround.

    I don't have a KA6, but i see it does have 2x2 outs, so i don't know if those have a seperate signal, and if they can be directed to headphones. If you have it connected, you should be able to see in osx audio midi controls how many in and outs it has.

  • Nico_NI
    Nico_NI BerlinAdministrator Posts: 654 admin
    Answer ✓

    This soundcard is more suited for DJing, it has the pre-listen feature:


  • Ruslan
    Ruslan Member Posts: 1 Noise

    i have a same problem, bud in windows x64, i try to use asio4all for pre-listein on my kontrol s2mk3 and komplete audio for main out, but no luck, is any who solve this problem? maybe it useless but i want 24\192 in my sets...

Back To Top