Installation Failed

DanGMF
DanGMF Member Posts: 1 Newcomer
edited January 2 in Native Access

I recently bought the kontakt 7 bundle for my M2 macbook pro which is running on Ventura 16.0 but i keep stumbling upon the "installation Failed" error when trying to install the stuff inside Native Access. I've already done what the website suggested me to do which is grant full disk access to Native Access and NTKDaemon then restart the computer, but that didn't seem to work for me still. I would really like some help please.

Answers

  • Sunborn
    Sunborn Member Posts: 2,179 Expert

    Hello,

    I assume you are using the new Native Access 2 and not the old Native Access.

    Also, as you mention, you followed that article https://support.native-instruments.com/hc/en-us/articles/360016913977-Native-Access-Error-Message-Installation-Failed-Mac- without success, right?

    Because many users report the same problem since months, i did a research for it, and found out some interesting info:

    1- For some reason, Native Access keeps setting the Applications/Native Instruments folder permissions for everyone, back to "read-only" when it starts up, which then fails the installations. It also occasionally fails on batch library installs, so you have to install one library at a time.


    2- Also, it seems that what the official NI article suggest, is not enough, at least on some systems. You also need to grand to NKTDaemon access to Files and Folders.


    However, i am on Windows not on Mac so i can not test this solution. Please give it a try, if it's successful it might help lot of other users too.

    Btw, this is a problematic development by Native Instruments, since the correct and easy way is to make NKTDaemon to "demand" those rights from the system, immediately after it gets installed.


    3- A more permanent solution might lays in System Settings > Users & Groups

    If your app installations fail on your Mac, you'll need to ensure you're logged in using an admin account. Standard user accounts don't always have the privilege or permission to install apps. You can simply log out via the main Apple menu and log back in on the correct admin account.


    Even better, give your self permanent Admin rights!

    I can't understand why people are afraid of this. Whatever warning you might read about this (for both Win and Mac) are totally silly and absolutely ridiculous for a modern user. That might had some value, 20 years ago. Every user must be an Administrator on his own computer.

  • Jay Ehhh
    Jay Ehhh Member Posts: 4 Newcomer

    This is what fixed it!

    After having the same issue on my Mac mini m2pro, I tried what NI suggested, but it still showed „Faild to Install“ error.

    But:

    after formatting my SSD to APFS every thing worked as expected.

  • D-One
    D-One Moderator Posts: 2,736 mod

    May I ask how did you end up with a modern mac with an SSD not in APFS? Or are you talking about an external SSD?

  • Maciej Repetowski
    Maciej Repetowski Member Posts: 369 Pro
    edited January 31

    Unless one is exchanging data with PCs and needs to plug external drive into PC sometimes - all Mac drives should be formatted as APFS.

  • Jay Ehhh
    Jay Ehhh Member Posts: 4 Newcomer

    @D-One 😂 you put the finger on it. It is an external SSD. Usually I format new drives, but somehow this time I didn’t.

    Anyways, a lot of posts I read involved external drives. So it seems the lack of foresight is not merely my problem.

Back To Top