Native Access (application location) RED

Doobox Member Posts: 35 Helper

Why is this (see image) native access > preferences > file management >

application location, showing in red, as if there's some sort of issue?

installing instruments does indeed install to that location without issue, so it's just a niggling annoyance on the face of it, as still seems to work fine. But what condition would trigger that error red highlighting?



  • Kunsterik
    Kunsterik Member Posts: 1 Newcomer


    I have the same issue. Applications are installing but the red checkmark is there.

    Red is usually not okay, so I wondering too.



  • PoorFellow
    PoorFellow Moderator Posts: 3,764 mod

    Ni Forum service person and MAC expert , Jeremy , is on leave until the 6th next month. But often on MAC it is a problem with security settings , disk access , file system type or in-compatibility with the MAC OS. I do not use MAC myself but I can paste a collection of AMC advice for you below here :

    Compatibility of Native Instruments Products on macOS :

    1) Check all folders in Download, Application and Content locations by doing Get Info in Finder for full Read and Write access permission. Click lock at bottom right to make changes.


    2). Be sure Full Disk Access is granted for NI applications under System Settings> Privacy and Security> Then under "Privacy Section" scroll down to "Full Disc Access" right arrow. Will open up the NI apps, and you slide them all to "on".


    If it fails immediately on download, it is probably disc write privileges, if it fails at last point in installation, probably Full Disc Access. When all is working you will see the temporary install folder for the app you are installing show up on your desktop. If you get that far, it should complete.

    Final Solution: For new MacBook Pro users or anyone using the M1 & M2 chips, Native Access will work as long as you have the permissions turned on under the privacy and security. So if you see Native Access and the other NTKDaemon on your list, make sure they are turned on and you see blue after you check them. If you don't see blue and if they don't appear in your drop down list under FULL DRIVE ACCESS then you will continue to have installation issues.

    Did everything explain above. Stil problem. Then formatting external disk to APFS. Everything works fine

    This works - change your designated File Management folders in Native Access Preferences to a drive that is Mac OS Extended (Journaled) format. If you, like me, are trying to install using ExFat Samsung T7 SSD it will not work.

    I had the same issue here, and there was one additional step that solved this: I had to change the permissions for the desktop. For some reason, "everyone" did not have read and write permissions for the desktop, and that somehow prevented the dmg to do its thing.


    (a) I gave full disk access for NI Access and NTK

    (b) changed the permissions to read/write for the destination folder

    (c) changed the permissions to read/write for the desktop

    and then it worked. Good luck guys!

    I've given full disk access to Native Access and the NTKDaemon, changed permissions on folders, and checked the APFS disk format, and the issues still happening. So I am not able to use or reinstall certain Kontakt libraries.

    Native Access's NTK Daemon: sometimes fails to install even with full disk access, also mutex issue

    Tips: Full Disk Access on Mac and why it matters

    Ref. : Native Access - Dependency Installation on Mac

    If the issue persists even after the steps you mentioned, please contact our support:

Back To Top