Mapping <move> command in Xone K2

Options
dger!co
dger!co Member Posts: 4 Newcomer
edited February 27 in Mapping Traktor

Hello

I'd mapped the <move> command with a modifier into the four upper encoders, one for each deck A,B,C,D and are only activated after pressing the button of the same encoder.

For some reason, after configuring all four in the same way, C doesn't work. When I turn the encoder it doesn't move. It's funny because I have other functions like gain, applied to this same encoder that do work fine.

Any idea what could be failing?

Thanks

Tagged:

Best Answer

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 2,084 mod
    Answer ✓
    Options

    Add the command 'Add In...➔Deck Common➔Move➔Mode Selector', one for each encoder, like this:


    If you want to move the loop while looping, add a second identical assignment with 'Set to value = Loop' and add a second modifier condition to both assignments; 'is in Active Loop (Deck)', with 'Value = 0' for the Beatjump assignment and 'Value = 1' for the Loop Jump assignment. This way you can have both.

Answers

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 2,084 mod
    Options
  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,838 mod
    Options

    Did you just duplicate the entries? Sounds like you did.

    Delete and add new command for Deck C.

  • dger!co
    dger!co Member Posts: 4 Newcomer
    Options

    Thanks for the answers. Deck that doesn't works is Deck C. As you can see it is configured in the same way than Deck that it works.

    First time I've duplicated the 4 entries for the decks, and after I tried to create a new Modifier 5 and a Move command only for Deck C. And still not working.

    Here the complete mapping 👇️


  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 2,084 mod
    Options

    There are two input lines for the modifier. The second one has ModifierX == 1 as a condition and switches it to zero. There first one switches it to ONE, but it doesn't have a conditional: Give it the condition Modifier == 0, so that it doesn't trigger at the same time as the second.

    This should make certain that pressing the knob toggles the modifier with a press (and release) from 0 to 1 and with a subsequent press (and release) from 1 to 0.

  • dger!co
    dger!co Member Posts: 4 Newcomer
    Options

    Thanks so much.

    And sorry to waste your time. I tried what you said and it didn't work either. It also didn't make much sense because the other 3 encoders were configured the same way and they did work.

    I've finally found the error and it's only mine, for newbies!! 😓. In the Move section of the Display I had Loop selected instead of beatjump, and that's why the timeline didn't advance when I turned the modifier.


    Sorry, sorry!!

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 2,084 mod
    Answer ✓
    Options

    Add the command 'Add In...➔Deck Common➔Move➔Mode Selector', one for each encoder, like this:


    If you want to move the loop while looping, add a second identical assignment with 'Set to value = Loop' and add a second modifier condition to both assignments; 'is in Active Loop (Deck)', with 'Value = 0' for the Beatjump assignment and 'Value = 1' for the Loop Jump assignment. This way you can have both.

  • dger!co
    dger!co Member Posts: 4 Newcomer
    Options

    I will try, of course :-) Thanks Sûlherokhh !!

Back To Top