'library path is invalid' error

BKK
BKK Member Posts: 4 Sine
edited February 25 in Native Access

I am trying to install a Maschine expansion (Altered States).

The licence shows up in my account, but when I try to install via Native Access, I get an error that the 'library path is invalid'. I've read the linked articles explaining this error, but the solution offered does not work.

The articles say to locate the library folder with the .nicnt file.

But I do not have an Altered States .nicnt file, because its not installed.

How can I get out of this loop please?

Thanks in advance.

Tagged:

Answers

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 844 Saw

    Expansions do not have a .nicnt file, only Kontakt libraries do. So you will never find or locate that file. Did you move the original installation of the expansion? Post your OS and exactly why it needs repair…

  • BKK
    BKK Member Posts: 4 Sine

    Thank you for replying.

    Yes, I moved everything to a new computer. All my other expansions/libraries made the transition, but it's possible that I had never installed Altered States on my old computer. (I have looked for it there, where all my other libraries are, but could not find a folder for it.)

    I need to install it on my new computer, but the Native Access app won't accept any path that I give it - it seems like its looking for an older installation.

    I'm on Mac OSX 12.2.1

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 844 Saw

    Not a Mac user, but I think it may have to do with disk Access... Here is a link to a post about it!!


    Tips: Full Disk Access on Mac and why it matters — Native Instruments Community (native-instruments.com)

  • BKK
    BKK Member Posts: 4 Sine

    Thanks for your reply.

    I've checked that, I still get the same error.

    ;-(

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 690 mod

    Hey @BKK Were you able to install all the other products ? Are you installing your content on an external hard drive ? What format is that drive ? Can you post screenshots of Native Access showing the error ?

  • BKK
    BKK Member Posts: 4 Sine

    Yes, I was able to install all the other products - previous to Native Access, then I moved to a new computer.

    Everything came across OK except Altered States, and its possible that I didn't install Altered States originally.

    There is no problem with the drive format, it is currently happily serving up dozens of other libraries just fine.

    The error I get is the same one described here: https://support.native-instruments.com/hc/en-us/articles/360000884238-Native-Access-Error-Message-Library-path-is-not-valid-Please-browse-again-

    The problem is NOT with my computer, its with your Native Access installer.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 690 mod

    Hey @BKK I see that you are in contact with my colleagues about this issue, you're in good hands, that should be fixed soon.

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 844 Saw

    I am Curious, when you said earlier that "but the Native Access app won't accept any path that I give it" were you referring to the Native Access install location "preferences" or were you referring to the Repair browse function... the reason I ask is that the repair function does not work for expansions, they require a full reinstall...at least that's the way it works on Windows (unless you don't mind messing with the "Registry".

  • Bald&clean
    Bald&clean Member Posts: 1 Noise
    edited May 10

    @BKK Did you ever get this resolved? I'm asking because I'm having similar issues in that I have previous libraries installed on an external, but it won't let me install something new because of an invalid path

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 671 admin

    Hi @Bald&clean it seems you're trying to install Noire, which is a Kontakt library from NI, while the OP is having an issue with a Maschine expansion from a third-party so the root cause might be different here. If you don't have success after following the steps in this video Setting Install Locations in Native Access feel free to create a new post!

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 671 admin

    BTW @BKK How did it go for you? Did the article suggested by the support team Setting Up a Third Party KONTAKT Library address your issue?

Back To Top